FiPy deep sleep high current



  • Hi!

    I'm working on implementing a sense, send, deepsleep, sense, send cycle on a FiPy using LoRaWAN (OTAA). Things are looking OK (the program is running its loop correctly), but the deep sleep current is higher than the idle (no radios) current. When I start my program I first turn off all unwanted radios (current drawn with LTE, Bluetooth etc on is around 260 mA). When they are turned off the idle (no radios) current is around 65-70 mA, which correlates good with whats written in the specs for FiPY.

    However, when I enter machine.deepsleep(20000) for instance the current rises to about 160 mA. Does anyone know the reason for this? Is there any periphirals that are turned on during deeplsleep? Is it drawing more because its relying on the timer? Is there any way of turning them off and getting a lower current?

    I'm running:

    Device: FiPy with ESP32
    Firmware: 1.17.3.b1
    Python: 3.4.0
    MicroPython: 1.8.6

    The following picture shows the current drawn from the board. An explanation of the intervals:

    1. Around 60 mA -> All radios turned off (already off because run program in (2) already)
    2. The peak of about 200 mA -> Running program that turns off all radios
    3. The drop down to about 170 mA -> going into deep sleep (doesn't make any sense)
    4. Peak of about 250 mA -> rebooting
    5. Drop down to around 60 mA again -> idle state with no radios on (Turning off all peripherals are in my boot.py)

    0_1524508420058_Skjermbilde 2018-04-23 kl. 20.31.34-kopi 3.jpg



  • This post is deleted!

 

Hello World?

Pylife on Kickstarter - November 2018








Back Us On Kickstarter >

Pycom on Twitter