New Firmware Updater version 1.14.2


  • administrators

    Version 1.14.2 of the firmware update tool is now available.

    This version is fixing an issue that would ask users for a Pybytes activation token in certain circumstances even though a stable firmware is being flashed.

    As usual please let. me know if you encounter any issues.



  • Perfect, thanks.
    This gives me what I need until it can be dealt with on your end. I have filed the ticket.


  • administrators

    @travist The device will still function with the LoPy firmware but the pins for the LoRa modem won't be usable.

    The fact that the board type cannot be changed after first registration with the online firmware updater has always been this way... the only thing that has changed is that the board type is now being shown in the updater, so you might just never have noticed before that you have the wrong firmware on your board.

    You can always download firmware packages manually and flash your board offline using the "Flash from local file" option.

    The links to the firmware packages can be found here: https://docs.pycom.io/chapter/advance/downgrade.html

    It mentions downgrade but it works just as well for the current firmware.



  • Thanks, and I submitted a ticket.

    You did not answer the other part of my question, is this device usable as a Wipy device with the type not being correct?

    Is this something that is newer for the updated, to not be able to select the type of firmware?


  • administrators

    @travist This means that the boards have been registered as LoPy instead of WiPy when flashing the boards for the first time.

    To change the registration of your board please run the following code:

    import machine,binascii                                                     
    print(binascii.hexlify(machine.unique_id()))
    

    Then open a technical support request at https://pycomiot.atlassian.net/servicedesk/customer/portal/ to request a device registration change.



  • I went to update my wipy 2 modules and it keep recognizing and flashing them as Lopy modules.

    Why?
    Is this going to cause issues for normal Wipy operation?


 

Pycom on Twitter