Firmware update not working (LoPy4, MacOS 10.12.6, Updater 1.14.2)



  • I'm following the steps at https://docs.pycom.io/chapter/gettingstarted/installation/firmwaretool.html#first
    but can't get the firmware update working

    1. Welcome Screen => version 1.14.2, I click continue
    2. Setup Instructions Screen => I press the reset button before I continue
    3. Communication Screen => I select the port /dev/cu.usbserial-DQ00DQGL (there is no other serial USB port). There are more options available than on the instructions web page mentioned above. Apart from the "High Speed transfer" checkbox (I tried both) there is also
    • Erase flash file system (I didn't check it)
    • Force update LoRa region (I didn't check it)
    • Flash from local file (I didn't check it)
    • Type: pybytes (default), stable, development (I tried pybytes and stable)
    • Force update Pybytes registration (I didn't check it)
    1. LoRa region selection screen => I chose Germany
    2. Pybytes registration screen => I skip it
    3. Upgrading... Screen => I wait 15 minutes, but it doesn't complete

    I have set the G23-GND jumper cable. TX and RX headers are in place.

    In System Information the device is listed as FT230X Basic UART

    I use an Expansion board v2.1A

    thanks for any suggestions


  • administrators

    @sukandar Thanks a lot.

    It seems the serial communication is working.

    Can you please try the following two commands next:

    cd "/Applications/Pycom Firmware Update.app/Contents/MacOS"
    "Pycom Firmware Update" -v
    

    This will open the firmware updater (please follow the same steps as before) but during the update it should print some text in the terminal window.

    Please send the output in the terminal window along with the wireless Mac address from the previous command and a link to this forum post to support@pycom.io

    Thanks a lot.



  • unchecking "High Speed transfer" and choosing the stable firmware did not help



  • Connecting via "serial USB" I get this

    ets Jun 8 2016 00:22:57
    rst:0x1 (POWERON_RESET),boot:0x2 (DOWNLOAD_BOOT(UART0/UART1/SDIO_REI_FEO_V2))
    waiting for download

    Executing the command line utility I get this

    Running in FTDI mode
    Connecting.......
    Uploading stub...
    Running stub...
    Stub running...
    Changing baud rate to 921600
    Changed.
    WMAC=xxxxxxxxx

    thanks for your help


  • administrators

    @xykon said in Firmware update not working (LoPy4, MacOS 10.12.6, Updater 1.14.2):

    ./pycom-fwtool-cli -p /dev/cu.usbserial-DQ00DQGL -v wmac

    I should clarify that it's not necessary to post the actual wireless Mac address on the forum. If it is necessary for further troubleshooting, I will ask for it to be sent via email to direct message.

    I'm only interested in the messages being shown when the firmware updater is trying to connect to the device.


  • administrators

    @sukandar Sorry the firmware updater was recently updated and we haven't had a chance to update the documentation yet.

    For starters please try with the stable firmware only until you managed to update the device.

    Beside changing the firmware type to stable, as a first try uncheck the "High Speed transfer" option and select 115200 from the drop-down box. Lowering the speed might already help.

    If it still fails please try to connect to the device via serial USB or Pymakr. With the firmware update jumper wire installed, you should see some messages including "Waiting for download" when you press the reset button. If you don't see any messages, either something with the serial communication isn't working or the device wasn't properly inserted into the expansion board.

    If you do see the "Waiting for download" message, please close the serial terminal program. Then please try to run the command line utility with these commands:

    cd "/Applications/Pycom Firmware Update.app/Contents/Resources"
    ./pycom-fwtool-cli -p /dev/cu.usbserial-DQ00DQGL -v wmac
    

    Please provide the output for further analysis.

    Thanks a lot.


Log in to reply
 

Pycom on Twitter

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.