<SOLVED> FiPy not detected on Win10 (using PySense)



  • Hi there,

    I have a FiPy board with the PySense board. The issue I am facing is that, if I am to connect the PySense board without the FiPy board it does show up in device manager.

    However the moment I connect the FiPy module to it and plug in the USB, nothing. I tried booting into safe boot, nothing. Could the FiPy be damaged? I have only used it twice and have not connected any peripherals to it except the antennas.

    Thanks
    Emil



  • Figured out the issue. Looks like the FiPy was consuming more current that my USB was able to deliver even though it was just running the sample PyMakr code of changing LED color.

    I connected a LiPo battery to it and didn't have an issue since.

    For those interested in figuring out how I got to this:

    1. I removed the FiPy module from the PySense
    2. Connected through USB to the computer and checked device manager for a new COM port
    3. If present, then PySense is fine.
    4. Without removing the USB to the PySense, I connected the FiPy and was able to program it.

    With the above basic steps you can determine if the board is actually bricked or just requires power.


 

Pycom on Twitter