Uploading project...



  • Re: [Code run _thread.start_new_thread](that includes AWS MQTT causes guru meditation)

    after upgrade firmware,

    I downgraded to the version at 1.17.3.b1 which worked first but I got the same problem ...
    use usb / serial 115200, I upgraded with both USB 2.0 and 3.0 and I deleted the flash before the upgrade

    >>>
    Uploading project (main folder)...
    Not safe booting, disabled in settings
    Reading file status
    [1/4] Writing file www/bootstrap/css/bootstrap.min.css
    Failed to write file, trying again...
    Failed to write file, trying again...
    Filecheck failed
    [2/4] Writing file www/js/angular.min.js
    Failed to write file, trying again...
    Failed to write file, trying again...
    Filecheck failed
    [3/4] Writing file www/js/jquery-1.11.1.js
    


  • hello, I think we are talking about the same problem in another post.

    Regards,


  • administrators

    @cmisztur Hi, which version of Pymakr are you using? We have done some improvements in version 1.4.2 which may have solved this issue.



  • Gotta bump this. Same issue here.



  • Same here with Atom+Pymakr and Lopy V1.18.0.
    However, all files are in flash after the upload, and working fine. Just get that error when uploading.



  • Hello @on4fg,
    The files are present on the board and the application works, the problem is that it sends them to each upload, and sometimes stops without coming to an end.

    could be a problem related to the ftdi adapter, I've tried both on usb2.0 and usb3.0 but nothing, I try to do a test with the prolific adapter we see what happens.

    VS Code + last pymakr plugin + various versions of the firmware, and with all the same problem

    excuse for my esy english
    regards
    Giacomo



  • @james
    Same here. i am just starting and working through the examples. After every try, I erase the flash.
    I enabled 'save boot' in Pymakr, but still got errors:

    0_1532675070716_2f5f4c31-24ea-4ab7-a2c3-cebf433e39c5-afbeelding.png

    When I check the content of the flash (I enabled Wifi and make a ftp connection), all files are there:
    0_1532675563202_eae48ca0-c053-478c-b8cb-ce41b201a79c-afbeelding.png
    And the program runs.

    Maybe you can verify if the files are on the flash

    I am running Pycom MicroPython 1.18.0.r1 and VS Code with Pymakr V1.0.1

    Good Luck,
    Stefaan


 

Pycom on Twitter