LoPy link error



  • I am building the latest firmware for LoPy (rev 1.18.1.r1) and I am getting the following error:
    LINK build/LOPY/release/application.elf
    lib/libfreertos.a(port.o):(.literal.pxPortInitialiseStack+0x0): undefined reference to _thread_local_end' lib/libfreertos.a(port.o):(.literal.pxPortInitialiseStack+0x4): undefined reference to_thread_local_start'
    collect2: error: ld returned 1 exit status
    application.mk:582: recipe for target 'build/LOPY/release/application.elf' failed
    make: *** [build/LOPY/release/application.elf] Error 1

    Can anyone tell me what I may have missed?



  • @robert-hh said in LoPy link error:

    pycom-esp-idf

    That was the problem. Thanks - everything works and firmware flahses fine.



  • @oldguydave
    I just tried buidling for LoPy here and ti worked fine.

    • Did you use the proper pycom-esp-idf library, which a git submodule update --init --recursive after cloning?
    • can you try a "make clean" in the esp32 directory and then a new build?

Log in to reply
 

Pycom on Twitter