Updating code is not working!!!

  • I'm trying to upload code to the board using the Pycharm with Micropython plugin. The Expansion does not respond.

    Connecting to COM7
    Uploading files: 0% (0/1)
    C:\dev\source\personal\embedded\pycom\blink\boot.py -> boot.py
    b'Traceback (most recent call last):\r\n  File "boot.py", line 12, in <module>\r\nKeyboardInterrupt: \r\nPybytes library: v0.9.0\r\nStarting UART...\r\n'
    Traceback (most recent call last):
      File "C:\Users\abc\.PyCharmCE2018.2\config\plugins\intellij-micropython/scripts/microupload.py", line 138, in <module>
      File "C:\Users\abc\.PyCharmCE2018.2\config\plugins\intellij-micropython/scripts/microupload.py", line 79, in main
        files.put(remote_path, fd.read())
      File "C:\Users\abc\AppData\Local\Programs\Python\Python37-32\lib\site-packages\ampy\files.py", line 157, in put
      File "C:\Users\abc\AppData\Local\Programs\Python\Python37-32\lib\site-packages\ampy\pyboard.py", line 192, in enter_raw_repl
        raise PyboardError('could not enter raw repl')
    ampy.pyboard.PyboardError: could not enter raw repl

    I have a demo to do with this stuff, please help.

  • @averri Besides that, I tried adafruit-ampy, which seems to be used by pycharm, and it works fine. Please be aware, that the files on the device mist be stored under /flash directory (or /sd, it mounted there). So a boot.py must have the target name /flash/boot.py

  • @averri Why don't you use ftp?

  • @dan I have done a factory reset (connecting G28 pin to the +3.3v). After that, I was able to upload the code again.

    I had tried Pymakr with VisualStudio, it was not working fine. The Pymakr with Atom is working, but I prefer to use the Pycharm, the IDE is much better in many aspects.

  • @averri Hi, any reason you're not using Pymakr with Atom or VSCode?

Log in to reply

Pycom on Twitter