VSCode connection timed out

  • I just got a new LoPy4 mounted on a PyTrack and cannot connect to the board at all through VSCode. I am using a Mac with USB-C ports and have a usb hub which the lopy4 is plugged into. The blue heartbeat is working and I can use the osx screen utility to connect to the board and run a few commands.

    In VScode when I run List Serial Ports I get

    /dev/tty.usbmodemPyb3c080 (Pycom) (copied to clipboard)

    I have switched between both

    /dev/cu.usbmodemPyb3c080 (which I see in /dev/)

    and on running Pymakr > Connect I just keep getting "Connection timed out. Click here to try again."

    I have tried pressing reset on the LoPy and nothing seems to work.


    	"address": "/dev/cu.usbmodemPyb3c080",
    	"username": "micro",
    	"password": "python",
    	"sync_folder": "",
    	"open_on_start": true,
    	"safe_boot_on_upload": false,
    	"sync_file_types": "py,txt,log,json,xml,html,js,css,mpy",
    	"ctrl_c_on_connect": false,
    	"sync_all_file_types": false,
    	"auto_connect": false

  • This is a new issue (please do not reopen old threads), only on VSCode, we are working on a solution. There's another thread here on the recent issues: https://forum.pycom.io/topic/6809/pymakr-1-1-8-vs-code-failed-to-connect/ In the meantime, you can use Atom + Pymakr. Sorry for the inconvenience


  • Facing the extract same problem in VSCode (connection timed out). Do you have a solution?

  • @dan

    Also for the screen utility on OSX I noticed I can only connect using

    /dev/cu.usbmodel* 115200

    /dev/tty.usbmodel* 115200

    Which is strange to me because the List Serial Ports command from the plugin show me the *tty.

  • @dan

    Still getting connection errors

    Found 4 serialports

    /dev/tty.usbmodemPyb3c080 (Pycom) (copied to clipboard)
    /dev/tty.MALS (Unknown manufacturer)
    /dev/tty.SOC (Unknown manufacturer)
    /dev/tty.TaoTronicsTT-BH07-CSRGA (Unknown manufacturer)
    Connecting on /dev/tty.usbmodemPyb3c080...
    > Connection timed out. Click here to try again.

  • This post is deleted!

  • @dfcarpenter have you tried restarting your Mac? Sometimes I had issues with serial ports and that usually solved it. /dev/tty.usbmodemPyb3c080 should be the correct one.

  • This post is deleted!

Pycom on Twitter