Sipy can't connect to Pybytes

  • Hello everyone,
    I am beginning with Pybytes and trying to use it in order to display some sensor values. The corresponding codes to retrieve all of them work. However, it looks like my Sipy device won't connect to my Pybytes account. However, I have been following every steps described here : and Then, when I try to upload the piece of code shown here as a test, I got this message : "cannot connect to Pybytes" or even "please review Wifi SSID and password inside config": However, I did put an existing Wifi and its corresponding password (I've tried both an eduroam network and my own phone hotspot) in order to connect (which I think, had to be done in Settings/Wifi credentials on the Pybytes platform) so I do not know where the error comes from. And also, when I used the firmware update tool and put my Pybytes token, there was a message which clearly said the connection to Pybytes worked.
    I am really not sure if my problem was clear enough so do not hesitate to ask if you need further information.
    Thanks for helping

  • @belal-chaudhary Can you confirm is your wireless network the standard wep/wpa-2 setup or does it use fancy certificate based authentication?

    Nothing strange going on Re Network proxy's like Eduroam/mobile providers are likely to have?

  • @paul-thornton hi! I'm having a similar issue using the WiPy 3.0 and PySense expansion board. I've connected to the device fine via Atom/PyMark, and also managed to FTP into when connected to the WiPy's wifi signal. I registered for PyBytes and it seemed to connect with the WiPy fine; now I'm trying to visualise some sensor values (using the same link provided by @brossingo) but it errors out as follows:

    Firmware: 1.18.1.r7
    Pybytes: 0.9.2
    Pybytes configuration read from /flash/pybytes_config.json
    Please review Wifi SSID and password inside config
    ERROR! Could not connect to Pybytes!
    Pycom MicroPython 1.18.1.r7 [v1.8.6-849-ac2b18f] on 2018-12-17; WiPy with ESP32

    I also checked the /flash/pybytes_config.json file via FTP, and the SSID and password in there seem correct. Any ideas on what to do? Would really appreciate any advice!

  • @brossingo

    Some mobile network providers do horribly strange things with network routing to avoid handing out a static IP per hotspot/phone/device. I wouldn't be horribly surprised to find out its the network and not your code/pybytes

    Any chance you could try it on a normal wifi network (Not Eduroam or one requiring a certificate to authenticate?)

    If it still fails on a "standard" wifi network please raise a support ticket or email and we will investigate further.

  • @dan I switched to my own phone hotspot and I could get the device to connect to Pybytes. However, I can not use this terminal for instance : 0_1542632605872_fb01ee00-a9ca-41aa-be1e-301ca03b4c80-grafik.png. I get this message next to the red sign even if my device is connected via USB to the computer and to Pybytes via hotspot. Do you know why I get this?

  • @brossingo eduroam won't work because it requires certificates, not just a password. It should however connect to your phone hotspot. Could you make sure you have to correct SSID? Have you tried another WiFi network apart from eduroam?

Pycom on Twitter