Failed to start STP mode!

  • This is what im getting on my computer(Ubuntu 16.04):

    >>> import sqnsupgrade
    >>>'/dev/ttyUSB0', 'NB1-40343.dup', 'updater.elf')
    <<< Welcome to the SQN3330 firmware updater [1.2.0] >>>
    Failed to start STP mode!

    Edit: I'm running this on my computer and I opened as "sudo python3"
    Edit 2: I'm trying to do this over UART since i don't have the expansion board aka no sd card.
    Edit 3: Tried to do also upload the 'upgdiff_33080-to-40343', same result as I have here.

  • Uploaded the diff and uploader files to the Gpy with the Pymakr and did the upgrade using the steps of the sd card but changing each path to flash.

  • @elizar said in Failed to start STP mode!:

    ccessible Sorry, I didn't specify enough, that is a python console opened on my computer in the path of the sqnsupgrade and NB1 files.

  • @oyarzo-pablo: Try leaving out the first parameter and specify only the *.dup and the *.elf files.
    Where are these files located? Are they accessible directly or do they need a path like /sd/updater.elf ?

Pycom on Twitter