PySense Firmware Upgrade - Device Not Recognized



  • Re: Pytrack and Pysense firmware release 0.0.2

    I am trying to load the latest firmware onto my PySense device using Windows 10. I followed the Firmware Installation instructions here as well as here.

    After plugging in my board following the instructions (hold button, plug in USB while holding, release after >= 1 second), no "Unknown Device" shows up on Zadig or on my Device Manager (my device manager doesn't show it under "Other Devices" or "Ports" even when plugging/unplugging it to do a dry run).

    I downloaded the dfu files and tried double-clicking them to install the applications to my computer. It just opened up the command prompt very quickly and then disappeared before I could do anything. I also tried navigating to the folders where I have the dfu unzipped folder and pysense_0.0.8.dfu files downloaded and ran the following command in both folders:

    dfu-util-static.exe -D pysense_0.0.8.dfu

    I got this output:
    0_1548122255516_PySense Firmware Probs.JPG

    Not sure what else to do at this point; any help appreciated!



  • @paul-thornton The timing is rather critical. Couldn't you extend the time window for updating to let's say 30s?


  • Global Moderator

    Also to note. Its a similar setup for the timing of Zadig. Get everything ready. Do the button + plugin. let go at the end of the chime Immediately hit go in Zadig.


  • Global Moderator

    So. The timing on going into firmware mode can be super awkward.

    Having done it a couple of hundred times lately here's some tips:

    Have the PC's sound turned up.
    Have the Command console ready with the command pre typed

    "dfu-util-static.exe -D pysense_0.0.8.dfu"
    

    and the window in focus. (so you can just hit enter and have it start).
    Have the Micro USB end already connected to the board.
    Hold the button down harder than you imagine.

    Plugin the PC end of the USB whilst keeping the button held.

    When windows finishes the little chime noise it makes for newly detected hardware (this is why we had the sound up).
    Immediately let go of the button and press enter on the keyboard. you have < 7 seconds to get it running before it switches back out of firmware mode.

    Sometimes itll take two or three tries but this is the most reliable trick I have found to getting the timing right.


 

Pycom on Twitter