Problems with Pymakr in VS code



  • Hello:

    I'm new and i tried to install Pymakr in atom and worked fine for now, but when i tried to install it on VSCODE, it didn't worked, the device is not connecting and it crashes.

    I got in the console this:

    Connecting on 192.168.4.1...
    Connection error: Error: Login timed out

    Where can i report this bug?

    Thank you


  • Global Moderator

    @nervencid With autoconnect to false, it indeed tries to connect to the address 192.168.4.1, so the output you posted is as expected. To connect you can either:

    • connect to the devices wifi and klik connect again, or:
    • change the auto_connect setting to true, or:
    • set the address setting to the correct comport (you can find it using the 'list serialports' command)


  • @ralph Hello and thank you for the answer, but the autoconnect is already in false, this is te configuration settings on VS Code:

    {
    	"address": "192.168.4.1",
    	"username": "micro",
    	"password": "python",
    	"sync_folder": "",
    	"open_on_start": true,
    	"safe_boot_on_upload": false,
    	"sync_file_types": "py,txt,log,json,xml,html,js,css,mpy",
    	"ctrl_c_on_connect": false,
    	"sync_all_file_types": false,
    	"auto_connect": false,
    	"py_ignore": [],
    	"fast_upload": false
    }
    

  • Global Moderator

    @nervencid On the bottom there's a button called 'all commands' which opens a list. In the list click 'global settings'. There you can change the 'auto_connect' setting.



  • @ralph Hello and thank you for the answer:

    How can i find the configurations for VS CodeĀ”

    Thank you



  • This is my project pymakr.conf in vscode

    {
        "address": "COM6",
        "username": "micro",
        "password": "python",
        "open_on_start": true,
        "safe_boot_on_upload": true,
        "sync_folder": "wipy"
    }
    

    If you are using USB you are going to want to fill in the COM portion. I haven't used the atom IDE yet, not sure if it is smarter.


  • Global Moderator

    @nervencid Did you set auto_connect in the global settings? This setting is not allowed in the project settings, so it's ignored. Which would result in the message you're seeing.



  • @ralph Thank you for your answer:

    The autoconnect via USB is enabled, and i am connecting via USB it works fine on atom, but it is not connecting on VScode


  • Global Moderator

    Hi @nervencid, can you provide any info on how it crashes? The 'Connection error: Error: Login timed out' is not a crash, it's that you are not connected to the boards wifi. If you want to connect over usb, I'd recommend enabling auto_connect in the general settings.


Log in to reply
 

Pycom on Twitter