Pysense new + Mac os x 10.14.3 ?

  • Pysense connected with USB-cable, device doesn’t show up.
    Tried installing FTDI-drivers, no result.
    Tried the D2XX-stuff, no result.
    Is there somebody who has this board working with this version OSX ?
    I never worked with pic-family.
    I have a pysense v1.0 + FiPy and wanted to do the firmware upgrade (pysense) first.
    Also looked at the video’s on Core Electronics.
    I measure no voltage on pin 5v ( connector to insert other board on top ) and 300mV on the 3.3V pin.
    On the external IO header i measure 3.3V on pin4 (3V3_sensors) but not on pin 3 (3V3_Pymodule).
    Do I forgot something ? Or is there something wrong with my board.
    My board has not the same component layout as the one shown on the webpage,
    some extra components near the USB-connector.(other version?)
    Now ordered an expansion board ( amazon prime ) to test my FiPy, but it is somewhere lost in space ?

  • @catalin

    Is it possible the pins of the external io header on the pysense are reversed in the online datasheet ?
    Pins 3 and 4 are reversed ? or the names are confusing ?
    For sure:
    Pin 4(ext io header) is coming from the voltage regulator.(5pins - pin5) ----- is called 3V3_Pymodule online.
    Pin 3(ext io header) is coming from FiPy 3V3 output and goes to the sensors (power). ----- is called 3V3_Sensors online.

    What is the purpose of control pin 2 PWR_EN (ext io header) ? connected by two resistors to pin GPIO24 I believe.

    Found some topics in the forum, but no clear answer and/or I'm looking at the wrong topics/datasheet.
    ( I always start with to search for information )
    I ask this questions because before buying other boards with that PIC chip, I want to understand the working and be sure not having the same problems again. I still can't imagine that all power (3V-5V) for the mounted module is coming from that PIC16lf1459 ( pin RC2 ).


  • @catalin
    Ok, thanx for your help and time.
    The FiPy is working fine. Didn't test all its capabilities but seems OK.
    Updated the firmware ( FiPy) and now it also works in Visual Code, mounted on the expansion board.
    ( In Atom it already worked on a breadboard and not updated. )
    Programming it 'over the air' also worked.
    Seems that I had bad luck with the pysense at first, but I learned a lot.
    Now the real fun begins.

    Perhaps one last question, why are there only 3 mounting holes in the pysense ?

    Thanx again.


  • @technoman
    The 3V3 it's output from Fipy, and it powers all Pysense sensors (also pull-up on I2C lines). So sensors should work.
    Does the Expansion v2.1 works with Fipy, can you connect to the REPL >>> prompt?
    There's no issue with Expansion v2.1 and Fipy in deep-sleep. With Expansion v3.x you'll obtain a better power-consumption in deepsleep (~30uA). Only the RTS/CTS jumpers from Expansion v2.1 should be removed for Fipy.

  • @catalin
    Ok, thanx anyway.
    Try to send it back and get my money.
    When this doesn't work, do you think it is possible to use the sensors on the board.
    The FiPy I can program over the air and the pysense 3V3 is ok. Just giving the mounted board 5V like on a breadboard.
    And yes I already tried the pysense on a bare linux machine, no result.
    So the PIC's are being programmed before mounting them on the boards, or are they programmed on the board and write-protected after ?

    My expansion board also arrived today, seem to have no luck with Pycom, it's a v2.1A with a FTDI-chip.
    Trouble again ? ( deep-sleep mode, updating, drivers ). I see only one button on the board and I read something about issues with deep-sleep mode.
    Should I give it a try or send it back direct ?


    Thanx a lot in advance.

  • @technoman
    So Pysense seems dead, if nothing appears on lsusb; either power problems, or the PIC is not connected with USB (PCB issues). Though do you have other computer (maybe Linux or Windows) to try it? I understand drivers could be messed up.
    Pysense PIC firmware can't be deleted, at least bootloader is write-protected, and it has to show some USB port on any OS.
    How did you connected Fipy with laptop? Using breadboard and UART2USB (FTDI) external chip?
    Yes, Expansion v3.0 has PIC and it should work out-of-the-box.

  • @catalin and @...
    Thanx for the help.
    Installed lsusb, with or without pysense connected, no difference.

    The expansion board v3.0 has also a PIC ? Does it has to be updated ?
    Because I ordered expansion board also, normally tomorrow delivery.
    First expansion board was lost ( Amazon, but I got my money back ), I hope it is version 3.0, normally it should be, but you never know.
    So with the pysense the PIC is dead or there is no firmware in it ?

    My FiPy, I tested without expansion board and is working fine at first sight, was able to program it with Atom+plugin, but till now not with VSCode+plugin. With VSCode no connection, but I think telnet is not installed by default on OS X, perhaps that's the problem.

    Last week I tested a ESP32-WROVER board with a SIL2104 on it, didn't work and the chip really was getting hot. I installed CP210X usb to UART bridge VCP driver for MAC OS X and problem solved. For the wrover board I'm getting /dev/tty.SLAB_USBtoUART after installing the driver.


    Always Thanx !

  • hi @technoman, could you try just connecting Pysense alone (no Fipy) with macbook.
    Either use Cmd+Space: System Profiler, or brew install lsusb to use a nice lsusb linux equivalent. To see if a new USB is detected.
    Using lsusb you'll see something like either:

    • normal PIC application mode (PID: 0xF012): Bus 020 Device 008: ID 04d8:f012 Microchip Technology Inc. Pysense Serial: Py06760a or
    • PIC bootloader mode (PID 0xF011): Bus 020 Device 004: ID 04d8:f011 Microchip Technology Inc. Application Specific Device

    This would show if PIC firmware is ok, so to split the problem firmware or hardware.

    Fyi: The Expansion v2.x has FTDI, while v3.x has the PIC.

  • @xykon That is exactly what I thought, it is not an FTDI chip.
    On the expansion board it's an FTDI-chip I believe.
    I must have followed a bad link somewhere, explaining the installation of those drivers.
    But my board is still not working.
    I measure no voltage between the pins where the FiPy gets is 5V ( see picture ), with or without FiPy mounted.
    I followed that pin somewhat and its coming from pin11(RC2) on the PIC16LF1459, where I also measure no voltage.
    So the mounted FiPy is not powered. Is power for the mounted board coming from the PIC16 ?
    Also tested my usb-cable.
    To me it seems like the PIC is not working, or there is no firmware in it ?


  • administrators

    @technoman The Pysense does not use an FTDI chip. It uses the CDC (ACM): Communication Device Class (Abstract Control Model) protocol which is natively supported by MacOS.

    We use MacOS internally at Pycom and I have the same version 10.14.3 on my MacBook Pro and the Pysense / Pytrack / Pyscan and Expansion Board 3+ all work without problems.

    On the external header pin 3 (3V3_Pymodule) is the 3V3 that comes from the voltage regulator on the FiPy. Are you still measuring 0V when a module is inserted properly.

    I measure no voltage on pin 5v ( connector to insert other board on top ) and 300mV on the 3.3V pin.

    Can you please clarify where exactly you are taking these measurements?

Log in to reply

Pycom on Twitter