WiPy 3.0 + PySense - Updated PySense FW, Cannot update WiPy 3.0 Firmware

  • So, I just bought a WiPy 3.0 and a PySense. I updated the PySense firmware to v0.0.8 successfully. The issue now is that I cannot update the WiPy 3.0 firmware.

    I tried running the pycom-fwtool on Ubuntu 16.04 and Windows 10.

    Here is the output from the CLI:

    $ sudo pycom-fwtool-cli --port /dev/ttyACM0 --speed 115200 --verbose wmac
    Running in PIC mode
    Product ID: 18 HW Version: 3 FW Version: 0.0.8
    Exception: Failed to connect to ESP32: Timed out waiting for packet header

    Here is the dmesg output for context:

    [621448.950856] usb 1-14: new full-speed USB device number 19 using xhci_hcd
    [621449.100507] usb 1-14: New USB device found, idVendor=04d8, idProduct=f012
    [621449.100508] usb 1-14: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [621449.100509] usb 1-14: Product: Pysense
    [621449.100510] usb 1-14: Manufacturer: Pycom
    [621449.100511] usb 1-14: SerialNumber: <snip>
    [621449.101550] cdc_acm 1-14:1.0: ttyACM0: USB ACM device

    Some additional notes:

    • The WiPy3.0 has a blinking blue light.
    • I was able to connect via telnet after connecting to the Wifi of the WiPy and got a REPL.
    • VS Code w/ Pymakr gets stuck trying to connect via USB serial
    • Tried two different quality usb to micro-usb cables with 4-pins.

    Here's the output I got from telnet/REPL:

    >>> os.uname()
    (sysname='WiPy', nodename='WiPy', release='1.7.0.b1', version='v1.8.6-621-g12ee404e on 2017-05-25', machine='WiPy with ESP32')

    Any ideas why I can't update the firmware or connect via USB/Serial?

Pycom on Twitter