Sequans Firmware Update Fails

  • I'm having some problems updating my GPy's modem via UART. I've uploaded the updater.elf file to the module and in Atom I've issued the following commands on the GPy:

    >>> import sqnsupgrade
    >>> sqnsupgrade.uart(True,'/flash/updater.elf')
    <<< Welcome to the SQN3330 firmware updater [1.2.5] >>>
    >>> GPy with firmware version 1.18.2.r7
    Preparing modem for upgrade...
    FFH mode is not necessary... ignoring!
    Do not specify updater.elf when updating!
    Attempting AT wakeup...
    Going into MIRROR mode... please close this terminal to resume the upgrade via UART

    I then close Atom and issue the following commands in the folder containing the .dup file and the sqnsupgrade scripts:

    developer@ubuntu18-laptop:~/Downloads/CATM1-41065/pycom-libraries-master/lib/sqnsupgrade$ python3
    Python 3.6.8 (default, Jan 14 2019, 11:02:34) 
    [GCC 8.0.1 20180414 (experimental) [trunk revision 259383]] on linux
    Type "help", "copyright", "credits" or "license" for more information.
    >>> import sqnsupgrade
    >>>'/dev/ttyUSB0', 'CATM1-41065.dup')
    <<< Welcome to the SQN3330 firmware updater [1.2.5] >>>
    Firmware file is too big to load via FFF method. Using ON_THE_FLY
    Attempting AT wakeup...

    However, the AT wakeup commands seems to fail and I get the following error:

    Traceback (most recent call last):
      File "<stdin>", line 1, in <module>
      File "/home/developer/Downloads/CATM1-41065/pycom-libraries-master/lib/sqnsupgrade/", line 1061, in run
        sqnup.upgrade_ext(port=port, ffile=ffile, mfile=mfile, resume=resume, debug=debug, pkgdebug=False, verbose=verbose, load_fff=load_fff)
      File "/home/developer/Downloads/CATM1-41065/pycom-libraries-master/lib/sqnsupgrade/", line 935, in upgrade_ext
        if self.__run(file_path=ffile, resume=True if mfile is not None else resume, direct=False, port=port, debug=debug, pkgdebug=pkgdebug, verbose=verbose, load_fff=load_fff):
      File "/home/developer/Downloads/CATM1-41065/pycom-libraries-master/lib/sqnsupgrade/", line 457, in __run
      File "/home/developer/Downloads/CATM1-41065/pycom-libraries-master/lib/sqnsupgrade/", line 149, in wait_for_modem
        raise OSError('Timeout waiting for modem to respond!')
    OSError: Timeout waiting for modem to respond!

    Any ideas?

  • @robert-hh Unfortunately I don't have an sd card to try updating it that way. Here's my output when I run the update with debug set to True.

    >>>'/dev/ttyUSB0', 'NB1-41019.dup', debug=True)
    <<< Welcome to the SQN3330 firmware updater [1.2.5] >>>
    File NB1-41019.dup has size 5835531
    mirror? False  recover? False  resume? False  direct? False  atneg_only? False bootrom? False load_fff? True
    baudrate: 921600 target_baudrate: 921600
    Setting port /dev/ttyUSB0
    Setting baudrate to 921600
    Initial prepartion complete...
    Loading NB1-41019.dup
    Firmware file is too big to load via FFF method. Using ON_THE_FLY
    Attempting AT wakeup... [921600]
    AT+BIND=AT returned b'\r\nOK\r\n'
    ATE0 returned b'\r\nOK\r\n'
    Entering upgrade mode...
    Sending AT+SMLOG?
    AT+SMLOG? returned b'\r\n+SMLOG: LOG_INHERIT\r\nOK\r\n'
    AT+SMOD? returned 2
    Sending AT+FSRDFILE="/fs/crashdump"
    AT+FSRDFILE="/fs/crashdump" returned b'\r\n\x00\x00/V\x00\x00\x00\x00\x00\x00\x00\x04\x00\x00\x00\x01\x00\x00\x00\x02\x00\x00\x0055.1.1.0 [33080] by robot-soft at 2017-10-27 07:49:11\x00\x00\x00\x00\x04\x00\x00\x03\xa8Assertion fai'
    AT+SQNSUPGRADENTF="started" returned b"ed\nFile: l1DspReset.c@96\n'LPU RIP: 00000000 00000003 00000000 (s->state ==ZSP_STATE_RUN || s->state "

  • @pycom_user123 I never tried the UART update. I updated from SD card, with the update script executed on the FiPy. That worked well.

  • Any recommendations on how I can troubleshoot this error?

  • Also, I am using GPy model v1.0 with firmware 1.18.2.r7. The pycom docs here => leads me to believe that GPy v1.0 can only support 6 bands (3, 4, 12, 13, 20, 28). I am looking to get support for band 8. Am I even able to update the modem firmware to a version that would support that band?

Log in to reply

Pycom on Twitter