Telstra Cat-M1 Coverage

  • Hi,

    I am using a fipy to connect to Telstra. It works fine in regular 4g coverage but when I go to a location that is supposed to have Cat-M1 but no 4g coverage then it drops out which makes me think that it is not using the full Cat-M1 network? I am comfortably within the coverage on the Cat-M1 coverage map.

    Could it be the Sim Card I am using? Or APN? I am using a M2Mone sim with telstra.internet.

    It says on the Telstra page that I shouldn't need an external antenna for the area I am testing but should I have an external antenna?

    Is this a pycom specific problem? I know in the early days there was a firmware issue. Is there something still not quite right?

    I understood that the Fipy can only communicate on the Cat-M1 network?

    This is the pages with the two different coverage maps.

    Any help would be appreciated.

  • It seems as if it has nothing to do with the Pycom as I tried an Arduino MKR 1500 on Telstra Cat-M1 and it had the same coverage as the Pycom. So I am following it up with Telstra and M2Mone.

  • @Edward-Dimmack That cmd is superfluous as far as I'm concerned, I use lte.send_at_cmd('AT+CGDCONT=1,"IP","telstra.internet"') initially then don't bother with it either, since the modem retains the info even through resets/power downs.

  • Yeh I am on LTE band 28 which according to M2Mone and Telstra is correct to get the coverage I am after. This is the at command I use.

    lte.send_at_cmd('AT!="RRC::addscanfreq band=28 dl-earfcn=9410"')

  • I've been tinkering with catM1 on a GPY & it's always on lte band 28 everywhere I try it. Areas with no band28 coverage don't work. I'm just using a regular Telstra data only sim I yanked from a phone.

Log in to reply

Pycom on Twitter