USB Serial Connection - GetOverlappedResult

  • I'm unable to connect to a new FiPy just out of the box and flashed with the latest firmware. The flashing process worked without fail and I got through successfully to the end. During the flashing process it made use of COM10, but VSCodium is trying to attach using COM3. I don't know if that matters or if I can override that.

    I'm flashing with the legacy firmware version 1.20.0.rc13. I'm using VSCodium 1.39.2 which works just fine connecting to a GPy unit, but not this FiPy.

    This is the terminal output I'm getting:

    AutoConnect enabled, ignoring 'address' setting (see Global Settings)
    Searching for PyCom boards on serial...
    Connecting to COM3...
    Connection attempt canceled
    Connecting to COM3...
    > Failed to connect (Error: Writing to COM port (GetOverlappedResult): Operation aborted). Click here to try again.
    > Failed to connect (Error: Port is not open). Click here to try again.
    Connecting to COM3...
    > Failed to connect (Error: Port is not open). Click here to try again.

  • Shortly after posting this I figured I'd better check the Device Manager on Windows 10. I found COM3 was registered to some Blue Tooth stuff so I went into settings and disabled BT since it's pretty much useless garbage on Windows anyway. I then was able to run VSCodium and it forced connection on the only remaining com port which was COM10. Still would be interested in how this wasn't scanning successfully for pycom devices though or maybe a way to override it.

    @oligauc I'll try the suggested override via manual selection. I was only connecting to one device. It has been some days since I've worked with the GPy unit.

  • @Sn3akyP3t3 In the pymakr there should be a checkbox to automatically connect to the USB, please uncheck this box and set the port manually. Pay attention if you are trying to connect to multiple devices at the same time. It will always try to connect to the latest attached

Log in to reply

Pycom on Twitter