Unable to flash

  • Hi,

    I'm trying to implement an accelerometer in a pytrack v1.1+ fipy combination. I uploaded a test project with the LIS2HH12 library to the device, but after that it seems to have gotten stuck and now it can't be connected to any of the tools I use (the visual studio code and atom terminals). Everytime I plug the device in VS it shows me this:

    Connecting to COM4...
    Failed to connect (Error: Writing to COM port (WriteFileEx): Invalid handle). Click here to try again.

    Since it can't be connected now I can't upload a new project or run any file from the terminal onto the device.
    I have tried safe booting with an expansion board and it doesn't solve it. I have also tried reinstalling the firmware with the pycom firmware update tool. Neither of these allow me to connect to the device so I can't remove the previous project or upload a new one. I would try to flash it from my pybytes account, but I as I am unable to run any code from the terminal or a file I can't connect the board to my WiFi. I need a way to effectively remove the files and connect the device to my pc again. I don't know what else to do. Any suggestions?

Log in to reply

Pycom on Twitter