Pytrack + Fipy not attaching to NB-IoT base station of TIM (Italy)

  • Hi guys,

    I am unsuccessfully trying to attach my Pytrack + Fipy board to the italian NB-IoT network of TIM (the SIM card from TIM should be ok). Here it follows the code:


    So what happens is that I never exit the loop because the "lte.isattached()" function always returns false.

    The AT+CEREG? command returns 2.2 but after a while (like many hours) it turns to 2.0 and so it stops searching.

    Furthermore, the AT+CSQ command returns 2,99 so likely I have a bad coverage but the TIM basestation is just in front of my apartment and so in some positions I am in Line-of-Sight (I am using the antenna recommended in the pycom guide).

    If I try with AT!="showphy", the board reaches the state CELL ACQUIRED but then nothing happens.

    Finally, RSRP is around -130 dBm.

    Regarding the firmware version I am using the following versions:

    • Fipy (V1.2) module: 1.20.1

    • NB-IoT firmware version: NB1-41019

    • Pytrack board: 0.0.8

    An idea could be to change the apn: does anyone of you has ever tried to connect to a TIM base station? Is there a way to know the correct apn?

    The band 20 should be one used by TIM for NB-IoT but I would be very grateful if someone could give some advises.

    In general, any advise and/or sharing of past experiences about this topic would be very appreciated.

    Thanks in advance

  • @robert-hh thanks for the suggestions but I have tried both strategies and they both lead me to the same unsatisfactory result. The code I shared is the one that seems to get closer to the success (cell_acquired state).

  • @GaioLampo please issue the attach command only once and do not repeat it in the waiting loop. And as you did in the loop, if you are not sure about the band, do nit specify it in the attach command. Then all suitable bands will be tried.

  • @agotsis thanks for the reply. The antenna I am using is exactly the one appearing in the following link:

    Recently I have also tried another one which provides better values (csq returns 18 and sometimes 31) but the result is the same I have described in the post.

    For the connector I am using the one on the bottom side which is the right one as you correctly pointed out.

  • @GaioLampo The 2,99 result for AT+CSQ seems rather low, although not sure if this is the reason that you can't get your module attached. What antenna do you use and are you sure you've attached it to the right connector? For the FiPy it is the one at the bottom (

Log in to reply

Pycom on Twitter