Unable to update firmware or use REPL on a new fipy



  • Hello!

    I have a fipy 1.0 and a Pytrack 1.1 that I am trying to get to work using Windows 10. I followed the getting started guide, and managed to update the firmware on the Pytrack.

    The issue appears when I try to update the pytrack with the pycom upgrade tool. It just times out with a "Failed to connect to ESP32: Timed out waiting for packed header".

    If i use putty and have a look, i sometimes see this:

    rst:0x1 (POWERON_RESET),boot:0x6 (DOWNLOAD_BOOT(UART0/UART1/SDIO_REI_FEO_V2))
    waiting for download
    

    And sometimes I see this:

    rst:0x1 (POWERON_RESET),boot:0x16 (SPI_FAST_FLASH_BOOT)
    configsip: 0, SPIWP:0xee
    clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
    mode:DIO, clock div:1
    load:0x3fff8020,len:8
    load:0x3fff8028,len:2136
    load:0x4009fa00,len:19880
    entry 0x400a05d0
    Smart Provisioning started in the background
    See https://docs.pycom.io/smart for details
    Pycom MicroPython 1.20.1.r3 [v1.11-58398d3] on 2019-12-12; FiPy with ESP32
    Pybytes Version: 1.3.0
    Type "help()" for more information.
    >>>
    

    I have not been able to type in anything or use any of the commands ctrl-d or ctrl-c in the terminal, so I am suspecting something might be off with the serial port set up. It does however show up as "USB Serial device" in device manager, so it is not clear if somethign is wrong.

    I have tried pulling P13 to high, G23 to GND. I have seen blue flashing, blue constant light and green constant light from the LED, but I am not able to crack the code here.

    Does anyone know how I could solve this?



  • @Gijs

    It shows up as a com port like this:

    Untitled.png


  • Global Moderator

    Can you check the device manager in Windows? With the Pytrack and Fipy boards plugged in, it should give a COM port. Indeed check if the drivers are assigned correctly. It could also be a power supply issue, as the ' waiting for download' happens if GPIO0 is low, which usually only happens when reprogramming the device.

    Let me know!
    Gijs



  • @audunab

    If you have installed the zadig driver, try to uninstall/deactivate it. This worked for my Win 7 system. But your system seems to work different. If I remember right, I never got a com port when the zadig driver was installed.

    Don't run update-software and the IDE parallel.

    Have you added hardware? I tried a lot of software stuff until I noticed the missing TX short of my Expansion Board 2 ;)



  • @robert-hh thanks for the reply.

    I have tried it without any success.

    I have also tried using teraterm and the platformio/vscode terminal without any success.

    Also: If it means anything, I see I have written "Updating the pytrack with the pycom upgrade tool", where it should infact say "updating the FIPY with the pycom upgrade tool." The pytrack upgraded fine.



  • @audunab please disable flow control in Putty.


Log in to reply
 

Pycom on Twitter