GPy LTE CAT M1 Connection Fails - Australia

  • Re: General LTE-M (Cat M1) connection problems thread

    So I've had a Pycom GPy 1.0 for close to 10 months now. I connected to the LTE Telstra network very successfully last year and did great work with it. It worked completely fine until early February this year when it simply stopped connecting to the network. I ran the same old code and then just to be sure reverted to basic LTE connection code on
    I double-checked the SIM card and it works fine. The antenna looked damaged and ordered a new one, which took over a month to arrived with all the pandemic. But even with the new antenna and a different SIM card, the device would no longer connect to the network. I also upgraded the Sequans firmware just to be sure.
    Has my device given up on me or do I have any other options to try out?

  • I've had 2 GPYs (out of 10) in the last 2 years where the RF section of the lte modem simply died. These RF dead modems show something bizarre like -1000 or -2000 for the Frequency Hypothesis RF (Hz) line in response to

    def send_at_cmd_pretty(cmd):
        response = lte.send_at_cmd(cmd).split('\r\n')
        for line in response:
    send_at_cmd_pretty('AT!="showphy"')     # get the PHY status

    run after trying to attach them, whereas an unsuccessfully attached modem with functional RF shows 0 for the frequency hypothesis.

Log in to reply

Pycom on Twitter