Firmware upgrade download



  • Hi All

    I am encountering the following error message when attempting to drag the Pycom Firmware Update into the applications folder on my Mac, in order to update my Pytrack firmware for the first time. Any clues? I can't seem to open it in any way? Could there be an issue with the macOS Firmware updater download on the Pycom website currently?

    Regards
    Jack

    Screenshot 2020-07-28 at 11.31.30.png



  • Solved after a reboot!



  • @WilkinsSq Can you strat the pycom updater directly from the DMG image?
    Both, starting directly and copying to the application folder works here, but with a very old version of OS X.



  • @Gijs Thanks for your response!

    I was indeed trying to download the firmware updater tool from the website. I was intending to use this to update the firmware of the Pytrack, until I read your link which states there are no firmware updates for the Pytrack 2.0 X.

    I still require the updater tool in order to register my Fipy with Sigfox.

    I am running macOS 10.15. When the firmware updater .dmg file downloads and is opened, I see this folder. Dragging the Pycom Firmware Update icon as requested into the folder does either nothing, or produces the error message above. The Pycom Firmware Update tool does not appear in my applications. Perhaps I have misunderstood how to use the tool?

    Screenshot 2020-07-28 at 16.24.24.png

    Regards
    Jack


  • Global Moderator

    Hi, I am not exactly sure what you are talking about..
    Do you want to:

    • Upgrade the firmware of the pytrack board
    • Upgrade the firmware of the -py module (like Lopy) on the board?

    For the first application, I recommend you check out this page: https://docs.pycom.io/updatefirmware/expansionboard/

    By default, you should be able to download the firmware updater tool from our website (https://docs.pycom.io/updatefirmware/device/) (for the latter application) and it should not give this error. I can not reproduce it in any way. Are you running MacOS 10.11 or higher?

    Best,
    Gijs


Log in to reply
 

Pycom on Twitter