Fipy LTE attached after a short time drop



  • I use m2m sim card and it is supported by local provider, I also connect the anntenna correctly. I am loading CATM1-41065.dup and fsm return wait_rss and csq returns csq: 99 (no data). then, I install NB1-41019.dup and fsm and csq return like the photos below

    WhatsApp Image 2020-08-10 at 13.36.47(1).jpeg
    WhatsApp Image 2020-08-10 at 13.36.47(2).jpeg
    WhatsApp Image 2020-08-10 at 13.36.48.jpeg

    WhatsApp Image 2020-08-10 at 13.36.47.jpeg

    after this proces fsm stuck in wait rssı
    Why cat m1 doesnt work and what is the nb1 problem? Can you please help me!!!



  • @Gijs firmware version is here
    WhatsApp Image 2020-08-11 at 09.51.20.jpeg

    I tried these commands respectively:

    lte.attach(band=20,apn="internet")
    
    lte.attach(band=20,apn="internet.m2m")
    
    lte.attach(band=20) 
    
    lte.attach(apn="internet")
    
    lte.attach(apn="internet.m2m")
    

    I activate my simcard before and check it. I also call turkcell and I confirmed they told me apn is internet.

    fsm output goes like this scanning-syncing-camping-camped-connecting-connected-
    disconnecting-camped-camping-syncing-camping after a while stuck in scanning

    csq output changes between 16,99-26,99.

    Thank you so much for all reply!
    I still couldn't solve the problem.
    Do you have any other ideas.


  • Global Moderator

    Hi,

    • You should always specify the band as a number (like lte.attach(band=20, apn='internet'),
    • Your modem firmware should start with LR6.xx ending in 5 numbers, as the provider uses NB-IoT, you can check it with import sqnsupgrade; sqnsupgrade.info(). The last 5 numbers correspond to the version.
    • I am not sure of the activation procedure with Turkcell, did you activate your simcard before using it?
    • There does seem to be coverage in your area as the CSQ command returns a value different from 99.
    • Does the FSM output look like this every-time? Try unplugging and reconnecting your module to hard-reset the modem.
    • Have you tried with- and without an apn? I cannot find the apn you specify anywhere on the page. It is also quite common for the apn to be like internet.m2m. It does not have to be internet, and can be like turkcell or the like.

    Unfortunately, every carrier handles things differently, which is why it does not always work first try.

    Gijs



  • @Gijs
    The error still persists.
    I am from Turkey
    my provider: turkcell
    APN "internet"
    I chose the band from this site.
    https://halberdbastion.com/intelligence/mobile-networks/turkcell
    I chose b20 as 20 and also try lte.attach(apn="internet"). Can you please help!


  • Global Moderator

    Hi,
    You did not specify which LTE version you are using to me yet. Choose the latest firmware version related to the LTE (CAT-M1 or NB-IoT) you need, you can find the pycom supplied images here: https://forum.pycom.io/topic/4020/firmware-files-for-sequans-lte-modem-now-are-secured/12. Please do not install older firmware versions.

    Let me know how that goes!

    Moreover, can you tell me more about the provider you are using and the country you are in?

    Best,
    Gijs



  • thanks for reply! ı connect with the provider and get apn name and band. ı also check it outside and ask the provider to network availability. Everything is okay. But ı still dont connected. I think problem is firmvare. How can ı choose the correct firmware ? I tried this firmwares http://stiny.webd.pl/PYCOM/. Can you please help me!!


  • Global Moderator

    Hi,

    First of all, does your carrier+simcard provide a CAT M1 or NB-IoT LTE connection? This is important as the firmware should be the same version. If you use the wrong firmware, it might seem to attach fine at first, but will later disconnect as it is not able to register, sort of like you are seeing here. Check the band and apn settings with your LTE carrier to see if they are correct.
    The code 99 of AT+CSQ also represents unknown, do not always trust on this to check your coverage. Do make sure though you verify your results outdoors as well. Getting a reliable LTE connection indoors is not always possible.

    Let me know!


Log in to reply
 

Pycom on Twitter