can't get PyMakr to start in VSCode



  • Already blown 1/2 a day trying to trouble shoot this and getting no where, please help!

    I followed the instructions on setting my PyMakr https://docs.pycom.io/gettingstarted/software/vscode/

    • I am using a Windows machine
    • I already had VScode installed with PlatformIO
    • I downloaded node.js 64 bit version, I couldn't get PyMakr to work, so removed and installed the 32 bit version as advised in Pycom trouble shooting. Both gave same result.
    • Confirmed Node is installed using node -v in command prompt (v12.18.3)
      16ea8d74-17d0-4a1a-b15c-cab6c48e97a5-image.png
      This is odd as VScode is saying it is using version 12.14.1 of Node.js
      e924b2a1-c7e9-4f71-bc29-e0b2081e8609-image.png
    • VScode version is 1.49.00
    • PyMakr plugin is v1.1.6, it is installed globally
      1af69e66-b2db-4421-b47f-c7fc55e74836-image.png
    • The PyMakr device is coming up as following COMM port
      deee1f8a-6d98-4670-9a44-915b3e75bbb6-image.png

    I am not getting the blue bar down the bottom. I have a purple bar which is from Platform IO.

    dff3fcf8-6ee9-4cbc-a5b2-cf0136153aa9-image.png

    Any help on what to do? Not sure where I have gone wrong. Thanks



  • Please check the new version 1.1.7!



  • @benc Yes, thanks, rolling back VScode one version worked. Appreciated!


  • Global Moderator

    Hi,
    Thanks for notifying us! We were not aware of the issue. Ill notify the developers!
    Gijs



  • This post is deleted!


  • I also have the issue since my VSCode updated to 1.49 (August 2020). Before this update, it was working.
    So I guess that the VSCode update has killed the PyMakr plugin, like has happened in the past

    If you manually install 1.48.2, it should work:
    https://code.visualstudio.com/updates/v1_48
    f0c9cfe6-7aa5-4224-a033-937092b216c7-image.png

    Then in settings, disable automatic updates.
    This worked for me. Will need to keep using 1.48.2 until Pycom release a fix for PyMakr


Log in to reply
 

Pycom on Twitter