Nothing Uploading-Endless Core Dump

  • We recently purchased 4 Fipy boards and only 3 are still functional. The other 3 are basically completely useless. Whenever I try to upload anything, it either tells me to do a manual reset (holding the button down practically never works and it takes roughly 5 minutes until something works) or it just starts core dumps, does an automatic reset, and repeats this process forever. Once in a blue moon something uploads, but this is completely unacceptable, especially since completely different programs have led to this same issue.

  • @rcolistete I seem to have got it working. I reloaded the firmware and wiped the file system while doing it. I'm still not entirely sure why the core dumps were happening in the first place (all I know is some exception was thrown), but hopefully it'll be fine for now. Thank you.

  • Firmware version ?
    Have you tried to erase the internal flash ? For example, using Expansion Board, Pytrack, etc :

    $ pycom-fwtool-cli -p /dev/ttyACM0 erase_all

Log in to reply

Pycom on Twitter