AWS IoT topic subscribe callback never called

  • Hello,

    I am using AWS IoT and I am trying to subscribe to a topic using the package "simple" or the code in the AWS example on pycom website. The subscription seems to be successful and I expect my callback to be called when i publish messages to the topic I subscribed to. I am, of course, able to publish without issues but cannot subscribe.

    I am testing everything using AWS tools. The integrated web-based client and observing events about "things". When i subscribe, I can see trace of this subscription and the fact it was successful. When i publish, I see my messages in the relative topics.

    Although I am using "simple" right now, I have tried with both simple and the guide in the pycom documentation. I suspect at this point a misconfiguration from the side of AWS. This issue seems to be silent though. Subscription and publishing is successful! Receiving messages is not.

    I was wondering if somebody has some advice or some experience to share about this issue.

    Just to recap:
    Certificates are correct
    Endpoint is correct
    Connection is successful
    Publishing is successful
    Policy is correct (can subscribe to anything)
    Subscription is successful
    -> Receiving messages is not successful <-

    any help is appreciated!

  • OKAY!

    The problem has been solved by adding a receive policy to the group the thing belongs to.

    "Effect": "Allow",
    "Action": [
    "Resource": [

Log in to reply

Pycom on Twitter