Is there a dog in my py?

  • Hi all,

    I have just received my fipy/pytrack modules and am trying to do run some of the examples. However I get a periodic "reset" signal

    rst:0x7 (TG0WDT_SYS_RESET),boot:0x1a (SPI_FAST_FLASH_BOOT)

    about every 30 seconds and my programs get interrupted and I end at the prompt. I have found out that when I run a program that uses (and feeds) a watchdog timer, everything works nicely. So maybe there is a (watch)dog activated in my fipy? I have tried to install another firmware (1.20.1.r2 instead of 1.20.2.r1) but it didn't help. How can I get rid of this annoying periodic reset?

    I have alredy tried the following (this is Ubuntu 20.04), but it does not seem to finish ok.

    pycom-fwtool-cli -p /dev/ttyACM0 erase_all
    Running in PIC mode
    Erasing the board can take up to 40 seconds.
    Exception: Timed out waiting for packet content

    Any hints?

    Kind regards, Claus

  • @Gijs said in Is there a dog in my py?:

    and clear the CONFIG and NVS partitions

    This seems to fix the problem for me. I had installed fresh firmware bur without resetting these two. Thanks again!

  • Yes, exactly the same issue! I'll try what is proposed over there, thank you very much!

  • Hi,
    Your issue might be related to this post:

    Can you perhaps try to install a fresh firmware and clear the CONFIG and NVS partitions?


Log in to reply

Pycom on Twitter