Cannot Connect to FiPy with Atom or VS Code



  • I am trying to connect for the first time my FiPy and PyTrack and it won't connect.

    I successfully updated the the PyTrack firmware thanks to the core-electronics videos but I am unable to update the FiPy firmware because seemingly for the same cannot connect issue.

    When trying to connect and update the FiPy firmware, I do the following:

    • Connect the board
    • Board shows up in Device Manager under Ports 'USB Serial Device (Com 3)'
    • Start the PyCom Firmware Updater program
    • Click through the screens
    • Updater attempts to get device info, but times out.

    When I connect it and open Atom or VS Code I get:

    Smart Provisioning started in the background
    See https://docs.pycom.io/smart for details
    Pycom MicroPython 1.20.1.r3 [v1.11-58398d3] on 2019-12-12; FiPy with ESP32
    Pybytes Version: 1.3.0
    Type "help()" for more information.
    

    It also gives me the python '>>>' but I am unable to type anything. In VS Code I can click the help command and get the help text but still can't type any of the commands .

    Please help...

    k.


  • Global Moderator

    Hi,
    Sorry for my late reply, I was refering to RX0, or P0. We use RX0 and TX0 to communicate the firmware and micropython code to the PIC, which we use as a USB-Serial converter (and some more things)

    Now P0 should be connected through to the PIC pin RB7, (if you orient the board so you can read the writing, it is the second pin from the left on the device marked PICxxx) directly so I'm not expecting any issues there (unless there is a bad solder connection, can you perhaps check that?)

    Though there is also micropython running on the Fipy, so we were once able to get firmware on the device, meaning it should just work..

    Can you contact me at support@pycom.io so we can discuss further options?

    Gijs



  • @Gijs Hi Gijs, thanks for your help on this. I am really excited to get this up and running so I can progress on my project.

    I have the diagram up and I just wanted to confirm that I understand what you are asking. I see many RX pins, could you clarify which one? (Attaching screenshot of diagram for your reference.)

    Also, when you say connected to the PIC, what is that and how is it connected? Are you talking about the actual soldered physical connection?

    Thanks again...
    k.

    FiPy Fiagram.png


  • Global Moderator

    So, to me it seems the RX on the Fipy is not working, also explaining why the firmware update does not work, but it does give output on the TX (like you mention, it brings up the micropython promt, but does not respond). I must say its not a common issue (Ive never seen it like this before). can you verify for me the RX pin on the Fipy (that should be P1) is physically connected to the PIC (sorry, I dont have a schematic on me at this time, that will be friday soonest)



  • Hi Gijs,

    I have the PyTrack non-v2. I had tried plugging things in and get it up and running and got to the Python prompt as I pasted above but I couldn't actually type anything at the prompt or run any card level commands.

    At that point I found Core-Electronics and his videos and went through his Getting Started, which started with updating the PyTrack board. This went swimmingly and concluded successfully. I then proceeded to attempt to update the firmware on the FiPy but got the timeout error when the update utility tried to pull card info.

    When I gave up on that, I tried again to plug in the FiPy and PyTrack board but still had the same problem.

    k.


  • Global Moderator

    Thanks for the clear problem description. Can I ask, which pytrack board are you using? Did the issue occur out of nowhere, or after updating the pytrack board?

    If you have a Pytrack 2.0 X board (with the external antenna connector), we have no firmware update published for that pytrack board so you might have updated the wrong firmware. If that is the case, I can provide you with the correct version

    Best,
    Gijs


Log in to reply
 

Pycom on Twitter