Issues uMQTT for connection to azure IoTHub

  • Hi,

    I'm trying to get my Fipy connected to Azure IotHub. Using this Repo on Github: link

    Problem is:

    • boot_dot_py code for connecting to wifi doesn't work: This one does: link but I'm not sure if it has an effect on how my data should be transmitted. If something in the file is using this...

    • I get some errors about a nonetype and not sure how to resolve this:

    File "", line 38, in <module>
      File "umqtt/", line 27, in reconnect
      File "umqtt/", line 23, in reconnect
      File "umqtt/", line 57, in connect
    TypeError: can't convert 'NoneType' object to str implicitly
    Pycom MicroPython 1.20.0.rc13 [v1.9.4-94bb382] on 2019-08-22; FiPy with ESP32

    I'm trying to use the example as is and didn't change anything except the obvious.
    Already tried and but that resulted in the same error.

    Anybody here an idea as where the problem resides?
    I also created an issue on the repository itself.

    Already a big thank you for the insights!

Log in to reply

Pycom on Twitter