WiPy 1.0 Bricked, Red Light on even after factory reset


  • Pybytes Beta

    I tried to upgrade the WiPy firmware as on the /gettingstarted instructions. Unfortunately, this made the WiPy unusable. When I start up the device, the red heartbeat light just stays on. Even if I do a factory reset (3.3V to Pin28) the heartbeat light flashes for 3 seconds, then faster for another 3 seconds, then even faster for another 1.5 seconds. Then the static red heartbeat light goes on again. Ive searched forums and asked around. My Dealer said I should contact you. Please can you help me. I was going to prototype a new alarm system (specifically for South African Homes) using this device, but with its failure I had to switch over to Raspberry Pi.



  • @josua
    Glad you got it working by doing the firmware upgrade procedure again



  • This post is deleted!


  • @josua @josua
    Nice, it works now. I tried to upgrade it once again doing this steps and it works:
    Disconnect your device from the PC.
    Connect wire G23+GND using a jumper cable.
    Connect the board to the USB.
    Run the upgrader
    Remove the G23+GND wire.
    Reboot the device (button or powercycle)



  • @jmarcelino Yes I tried resetting it and I tried to boot in safe mode. Nothing changes... The red light stays on. I also tried to connect to SiPy via Putty COM and what I see is only the black terminal screen. And last, when my SiPy is on, there is no Wi-Fi connection to it.



  • @Foennie
    my few wipy work near continously near half of year
    maybe you have bad one


  • Pybytes Beta

    I have been unable to solve this. I had to take it back to the supplier. After 2 weeks they told me that they too could not fix it, so they ended up replacing it for me. I think this device is soooo dainty. Its definitely not a robust industrial grade solution. Mostly home and Project use.



  • @josua
    The SiPy is a very different device, have you tried resetting it, for example by pressing the reset button?



  • @Foennie Hi, I have exactly the same problem with my SiPy after upgrading with the latest firmware.. Did you solve it?



Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.