Need Help with resetting Fipy to Factory Settings



  • Hi need help with resetting Fipy to the factory settings. was trying to configure lorawa nano gateway and suddenly the below issues started. Connection type USB Serial FTDI.

    • heartbeat led indicator not working.
    • tried to reset the device still heartbeat is not working like it used to.. when I run the code for a heartbeat it works.
    • Earlier while booting it use to display WIFI connection and LORA, but Now displaying WIFI & LTE.

    have tried most of the solutions. include (p12+3.3v) still the same with the board.



  • @Gijs thanks a lot Gijs.. will get back if any issue.


  • Global Moderator

    Right, it mentions Initializing Wifi and LTE though its always either one, so no need to worry there (they both use the same method as its an internet interface, whereas LoRa uses a different backend. Pybytes will prioritize connect to the network listed first in the network preferences item



  • @Gijs Thanks a lot.. this code is working and the heartbeat function is working now. .. but this new issue am noticing is once I connect to atom via com port - " Initialized watchdog for WiFi and LTE connection with timeout 1260000 ms
    WiFi connection established
    Connected to MQTT mqtt.pybytes.pycom.io
    Pybytes connected successfully (using the built-in pybytes library)
    Pybytes configuration read from /flash/pybytes_config.json
    Pycom MicroPython 1.20.2.r4 [v1.11-ffb0e1c] on 2021-01-12; FiPy with ESP32
    Pybytes Version: 1.6.1, "
    whereas I have only enabled Lora & wifi connection only in pybtes.



  • @Gijs will give it a try & update. when I am trying to upload a new configuration via pymaker the release details are not getting updated.


  • Global Moderator

    If you're looking to specifically activate the heartbeat, I would suggest you use the following:

    import pycom
    pycom.heartbeat_on_boot(True)
    #and / or
    pycom.heartbeat(True)
    

    So you're not having any issues with updating the firmware and safebooting I presume?

    Gijs



  • Hi Gijs,

    have updated so many times.. still heartbeat not working. even tried erasing NVS, config & flash also. safe boot option also has been tried.


  • Global Moderator

    Hi,
    Have you tried using the firmware updater tool, select advanced options and tick all the boxes (erase NVS, CONFIG and flash)

    Does the safebooting work for you?

    Let me know
    Gijs


Log in to reply
 

Pycom on Twitter