Red led



  • I'm having some troubles with some of my lopy4s.

    Few days ago I had some troubles uploading some scripts to my devices and I decided update the last firmware version because I was working with a legacy one (1.18). The goal of this action was have my devices like as factory.

    The problem is that when I update it all works fine, but then when I start working with they the led lights red (I think is when I reboot the lopy) and I can't use them anymore.

    I tried enabling and disabling all this options, but still crashing.

    Captura.PNG

    Can somebody help me? Now I have 3 lopy4s that I can't use :(

    Thank you very much.


  • Global Moderator

    The 'erase all' is indeed different from the 'erase flash' and 'clear CONFIG / NVS partitions' in the firmware updater tool. Im not sure exactly, but in most cases the 'erase all' in the command line works better than the latter methods, and could indeed provide a solution here



  • This command is on (Linux) terminal. On Mac OS and Windows only the serial device name changes.



  • @rcolistete Hello! Probably is a silly question but where (or when) I have to write this command? In my Atom console?

    I'm using the Pycom Upgrade program to format my devices right now.

    Thank you.



  • Have you tried (or with another device port) ?

    $ pycom-fwtool-cli -p /dev/ttyACM0 erase_all    
    

Log in to reply
 

Pycom on Twitter