FiPy +PyTrack 2.0 deepsleep power consumption

  • Hi all,

    I'm working on a tracking device with the FiPy (1.20.2.r4) with LTE modem firmware LR5.2.1.0-48829 (Cat-M1) and the PyTrack 2 (v16). Specifically, I am having problems with the deepsleep energy consumption. The boards are being powered via microUSB with 5V.

    I've seen that there is a recent topic about the consumption in the Fipy, but I haven't found a solution following those advices: when using the scripts suggested by @Gijs, I get values around 4.5mA, instead of something around 30uA. As I'm workig with a Pytrack2, I also tried to use the go_to_sleep method as suggested here, but the results are even worse (5.5mA).

    I would appreciate any help to try to solve this issue.

  • @Naroa-Echarte Since you're using a FiPy, it may be due to the LTE modem staying on (though I believe in this case you would get a much higher power draw). You may want to try:

    • disabling LTE on boot:

    • properly resetting the LTE modem before deep sleep:


    See for more information.

  • Sorry for my late reply, I had some issues with the current measurement system.

    As suggested by @jcaron , running the tests on battery solved the problem. I got 12uA @3.75V using the ultra low power mode. After that, I tried the low power mode of the script, the one that keeps the accelerometer on. I measured 480uA, when I'm supposed to get ~165uA @3.75V. Looking at the link provided by @Gijs , it seems that the value corresponds to the py.gps_standby(True) mode. I've tried to hardcode py.sensor_power(False) and py.gps_standby(False), but I can't get any value lower than 480uA.

  • There's also different power modes on the GPS that you could look at (maybe causing the 1mA increase between 4.5 and 5.5). I describe them here:

  • Hi @jcaron,
    Thanks for your help, I didn't know that the power supply could cause such a difference in the consumption. I'll run some test in the next few days following your suggestion, and I will let you know the results.

  • @Naroa-Echarte deep sleep is designed for running on battery, not powered via USB. There are a few things which are optimised for the battery scenario and not at all for the USB scenario (quite the opposite in fact).

    Start by running from battery to see if that helps.

Log in to reply

Pycom on Twitter