Pymakr 1.1.13 does not work with VSCode 1.60.0



  • There is no terminal window opening.

    List serial ports command leads to an error:

    1ef9c9b5-287e-4305-8ff8-c1ecdd7d06b3-image.png

    what can I do?



  • edit: I got around the last problem below by editting the Pymakr > Global Settings file and removing one of the manufacturer strings (my fypi extension board happens to have Microsoft as Manufacturer string).

    Victory! It took a bunch of hours, but it's fun now that I can start coding :P



  • Since I can't edit my post due to the way this forum is configured, I'll just continue in a new post. This is probably useful to people who run into the same problems as me.

    So continuing from the steps above:

    1. Downgrade PyMark from 1.1.13 to 1.1.12 (yes really, you have to downgrade both VScode AND Pymakr),
    2. Find out that the .inf driver that I installed (according to the tutorial) is actually not working (PyMakr doesn't see the Comport after installing the .inf driver) and I needed the standard Windows driver all along,
    3. Pymakr doesn't find the correct serial port. solution from the tutorial "If not please manually copy the correct serial port." Uhm? Copy? And then? To where? Not siuor wut do now, pls finnush sentence. k thnx bye.


  • A little rant about my first experience with trying a PyCom module. Hopefully it can serve as constructive feedback to the devs. Sorry if it's a bit emotional, I guess I'm a bit emotional right now :P

    There's something contradictory about this product: as far as I understand it was designed to be as easy to use as possible, yet in my experience it is way harder to get started than with a standard crappy microcontroller IDE using C++ from a whatever manufacturer.

    Steps I'm going through right now after hours of trying to get the tool-chain to work:

    1. Decrypt my Bitlocker drive, so that I can:
    2. Disable secure boot (without having to enter a Bitlocker recovery key), so that I can:
    3. Enable installing an unsigned driver,
    4. Install the unsigned COMport .inf driver,
    5. Install NodeJS,
    6. Find out there's a bug between PyCom and the current VScode version,
    7. Downgrade VScode,

    Can I start coding at some point or does the list go on? :P



  • @Stephan-Elsner wait for Pycom to fix this or downgrade to VSCode 1.58.2 and Pymakr 1.1.12


Log in to reply
 

Pycom on Twitter