Pymakr 1.1.13 does not work with VSCode 1.60.0



  • There is no terminal window opening.

    List serial ports command leads to an error:

    1ef9c9b5-287e-4305-8ff8-c1ecdd7d06b3-image.png

    what can I do?



  • @robert-hh Thank you! I will try to use these ways to upload the files to the WiPy card, right now I managed to get Atom working with Pymakr on Ubuntu, although it is working for the moment I don't trust Pymakr very much anymore



  • @jchernandez mpremote has a --help option. For copying files, you have to use the cp subcommand. So as example for copying a file to the board:

    mpremote connect /dev/ttyUSB0 cp myfile.py :myfile.py
    or just
    mpremote connect /dev/ttyUSB0 cp myfile.py :
    for using : as a shortcut for the baord's local directory and . for the PC's one. Copying back similar as:
    mpremote connect /dev/ttyUSB0 cp :myfile.py myfile.py
    or
    mpremote connect /dev/ttyUSB0 cp :myfile.py .

    The device names at Windows are similar COM3, COM4, .... Shortcuts are:
    u0 for connect /dev/tty/USB0

    Unfortunately the mount command of mpremote does not work with the PyCom version of MicroPython. That version is too old.

    To run a local script without copying it to the board use the run command. If you do not enter a command after the connect, mpremote opens a REPL session.

    And before I forget it: With Pycom devices and WiFi active you can always use FTP for copying files. A good FTP client is FileZilla. But some file managers allow using FTP paths as well. User name is micro, password is python.



  • @Meric-NESSANGE Hello, how can I upload files to a pycom board through mpremote? My atom and pymakr updated automatically and now no working anymore :/



  • @Meric-NESSANGE looks like the wrong com port.



  • EDIT : OK, wiring issue !

    58043392-e309-470a-a735-2604fd037416-image.png

    I'M CONNECTED ON A MICROPYTHON ^^



  • @robert-hh

    connected !!!
    --help was the enabler ^^
    Thanks.

    Unfortunately, not any ">>>" in the prompt. So no way to do anything...

    80c6e3b4-f1c0-4141-90a0-ee5ec987faeb-image.png



  • @Meric-NESSANGE Ftp must be unencrypted and limited to 1 connection.

    for mpremote you have to specify e.g. /dev/ttyUSB0 as interface. Shortcut is u0. E.g.

    mpremote connect /dev/ttyUSB0 ls

    or

    mpremote u0 ls

    For a windows machine, you have to specifiy the com port.

    mpremote connect com3 ls

    See also mpremote --help.



  • Hi @robert-hh,

    OK, I'd some unsuccesful try.

    Please, can you crosscheck my parameters :

    • ftp (by WiFi)

      • connect the PC to the micro wifi
      • host name : 192.168.4.1
      • port : 23
      • user : micro
      • pw : python
      • protocol : FTP (w/o encryption)
    • mpremote

      • succesfully installed with pip
      • got a "no device found" in the cmd panel. Seems not recognized as an application. Any idea ?

    Thanks.



  • @Meric-NESSANGE To upload the firmware you can always use the Pycom updater tool. And to upload code to the device you can use:

    • ftp (by WiFi)
    • mpremote by USB
      ....

    As terminal emulator you can use putty (windows), screen (mac), screen or picocom (Linux)
    As IDE you can as well try Thonny.



  • @robert-hh
    Thanks for answer.
    Yes, it barrely worked, but I update VSCode in order to solve some connexion issues.
    Noob error : I don't notice my previous version of VSCode.

    ok, rolled back to a supposed functionnal version :

    25f7c008-2475-4587-8c1d-538a02f1cb6e-image.png
    šŸ¤¦ā€ā™‚ļø

    ok, let's do it without the preview module :

    68551621-982a-416f-a84e-f75aa128390f-image.png
    šŸ¤¦ā€ā™‚ļø

    @g0hww It seems to be permanently broken with Atom
    šŸ¤¦ā€ā™‚ļø It was my B-plan.

    Anybody for a C-plan to be able to flash a board ?

    Everything is falling apart around here.
    Same sensation.
    And it's worrying.
    Really.



  • @robert-hh It seems to be permanently broken with Atom, which was when I last checked, apparently considered to be abandoned. Everything is falling apart around here.



  • @Meric-NESSANGE If it ever worked, roll back to these versions. If you never used it, my personal opinion would be to stay away from it. According to the complaints in the forum, Pymakr has problems with almost every update of VSCode.



  • Hi @robert-hh.
    till 1.1.12 ?



  • @Meric-NESSANGE Roll back VSCode.



  • Hi,
    Same Issue here : "command not found" in VSCode
    I use pymakr v2.22.4 and VSCode 1.70.0

    Any workaround to share ?

    Thanks.



  • Hi everyone. We've released v1.1.14, which should fix all issues directly related to v1.1.13.

    For questions and feedback regarding v.1.1.14, please see the thread below.
    PyMakr v.1.1.14 thread.



  • I think I have run into this the last few releases on VSCode and Pymakr. I have finally bitten the bullet and have turned off automatic updates in VSCode so I can hold them at the versions you called out. I'm not sure why VSCode and Pymakr keep having this problems on new releases, however I love how well they work when they do work, and didn't need to pay for either so can't complain :)



  • Same problem here, macbook pro:

    Version: 1.60.2
    Commit: 7f6ab5485bbc008386c4386d08766667e155244e
    Date: 2021-09-22T11:59:27.195Z (1 wk ago)
    Electron: 13.1.8
    Chrome: 91.0.4472.164
    Node.js: 14.16.0
    V8: 9.1.269.39-electron.0
    OS: Darwin x64 19.6.0
    

    Tried both 1.1.12 and 1.1.13 versions of the plugin, no luck, it does not appear in terminal and when trying to run console commands it says: command 'pymakr.connect' not found
    Thank you!
    R



  • edit: I got around the last problem below by editting the Pymakr > Global Settings file and removing one of the manufacturer strings (my fypi extension board happens to have Microsoft as Manufacturer string).

    Victory! It took a bunch of hours, but it's fun now that I can start coding :P


Log in to reply
 

Pycom on Twitter