Current LTE Firmware update process bricks FiPy's

  • I have an issue with 2 FiPy's related to LTE Firmware updates. The age of both FiPy's is the same, however one is still new-in-box and the other has been used for other projects. I followed the FiPy firmware upgrade process and that worked fine.. upgraded to 1.20.2.r6 - Then followed the LTE firmware update process with the latest firmware.

    The first(of two) LTE Firmware upgrades worked fine on the first(used) board, but I missed the step to run the second update file before resetting. Unfortunately after the reset, I was unable to access the LTE modem at all. "Could not detect your modem!".

    So I figured I screwed up the process and bricked my modem. I unwrap the 'unused' FiPy and followed the same process. Main firmware update, then LTE update process... THIS time, after the first upgrade file, the modem refused to reset and became completely unresponsive, unable to complete the upgrade using the second file.

    At this point, both FiPy's behave in exactly the same way. The modem is entirely unusable. has "NONE" listed for ALL outputs. No response from modem at all. I read some forum posts and there was a suggestion to do a uart upgrade.. that doesn't work because the modem is undetectable.

    Very rarely, the fipy will boot (usually after being unplugged for a while), and some LTE commands will work. My file has some lte commands, and normally they just hang with an error - however VERY VERY rarely,(as in twice...) the initial lte = LTE() will complete rather than hang with an error of "OSError: Couldn't connect to Modem (modem_state=disconnected)". Sometimes the modem_state is 'Connecting' rather than disconnected, usually immediately after reboot, but changes to disconnected after a period of time.

    Is there any way to resolve this? I can't run any commands to initiate an upgrade process at the moment. Even those rare times where the boot LTE commands will seem to work, follow-up commands fail.. such as sqnsupgrade.uart(True).

    Any help is appreciated! LTE support is the only reason I purchased these boards, and the standard upgrade process bricking them is frustrating to say the least.

    Also - I'm using pymakr expansion board 2.1A

Log in to reply

Pycom on Twitter