PyMakr 1.0.0.b5-1 can't set editor fonts under Kubuntu 16.04



  • I am running PyMakr 1.0.0.b5-1 on a Linux box with Kubuntu 16.04 and python 2.7.

    1. It is possible to set the font size in the editor settings but not the font. I would like to use a monospaced font but it is stuck with Oxygen Sans even after a restart.
    2. Furthermore it is not possible to change anything font related in the REPL shell at all. The changes in the Settings menu are excepted but nothing changes.
    3. As I've mentioned in another thread (just to keep everything here in one place), it is not possible to connect to a LoPy via WiFi which is connected by a local WiFi access point even though it is reachable by telnet and ftp from the CLI.
    4. The PluginUpdate throws an error when a LoPy is connected by USB. I tried to deactivate the - at least for now useless - plugin but can not untick the two options in the Plugin Info menu.

  • Pybytes Beta

    I don't get why releasing versions known to be buggy ... seriously guys, you made a realy astonishing job with your boards, but software is not at the same level.



  • @peter Sorry for my late response on this. Thanks for the detailed reports. The NoneType exception has been noted and fixed. The fix will be there in the next release (probably next week). Same for any issues with the PluginUpdate.


  • Pybytes Beta

    I'am getting the same error using Linux Mint.

    Platform: linux2
    2.7.6 (default, Jun 22 2015, 17:58:13)
    [GCC 4.8.2]

    Plugins Version Numbers:
    PluginAbout 6.1.0
    PluginAboutPymakr 1.0.0
    PluginCodeStyleChecker 6.1.0
    PluginCompletionJedi 1.0.3
    PluginEricapi 6.1.0
    PluginEricdoc 6.1.0
    PluginFeedback 1.0.0
    PluginFullUI 1.0.0
    PluginLiteUI 1.0.0
    PluginPycomDevice 1.0.0
    PluginPycomStyle 1.0.0
    PluginPycomSync 1.0.0
    PluginREPL 1.0.0
    PluginSyntaxChecker 6.1.0
    PluginTabnanny 6.1.0
    PluginUpdate 1.0.0
    PluginVcsMercurial 6.1.0
    PluginVcsPySvn 6.1.0
    PluginVcsSubversion 6.1.0
    PluginVmListspace 6.1.0
    PluginVmTabview 6.1.0
    PluginWizardE5MessageBox 6.1.0
    PluginWizardPyRegExp 6.1.0
    PluginWizardQColorDialog 6.1.0
    PluginWizardQFileDialog 6.1.0
    PluginWizardQFontDialog 6.1.0
    PluginWizardQInputDialog 6.1.0
    PluginWizardQMessageBox 6.1.0
    PluginWizardQRegExp 6.1.0
    PluginWizardQRegularExpression 6.1.0

    Distribution Info:
    /etc/os-release
    NAME="Ubuntu"
    VERSION="14.04.3 LTS, Trusty Tahr"
    ID=ubuntu
    ID_LIKE=debian
    PRETTY_NAME="Ubuntu 14.04.3 LTS"
    VERSION_ID="14.04"
    HOME_URL="http://www.ubuntu.com/"
    SUPPORT_URL="http://help.ubuntu.com/"
    BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/"

    /etc/lsb-release
    DISTRIB_ID=LinuxMint
    DISTRIB_RELEASE=17.3
    DISTRIB_CODENAME=rosa
    DISTRIB_DESCRIPTION="Linux Mint 17.3 Rosa"



  • The error occurs when I start PyMakr with a LoPy attached by ttyUSBx. It is reproduceable by disconnetcing the LoPy and reconnecting it again. My guess would be that it is the same problem that prevents the firmware update from happening.

    It reads as follows:

    2016-10-20, 21:15:31
    --------------------------------------------------------------------------------
    <type 'exceptions.TypeError'>: 
    'NoneType' object has no attribute '__getitem__'
    --------------------------------------------------------------------------------
      File "/usr/share/pymakr/modules/Plugins/PluginUpdate.py", line 137, in processPycomDeviceVersion
        product = PycomDeviceServer.uname[0].lower()
    
    --------------------------------------------------------------------------------
    Version Numbers:
      Python 2.7.12
      Qt 4.8.7
      PyQt 4.11.4
      sip 4.17
      QScintilla 2.9.1
      WebKit 537.21
      Pymakr 1.0.0.b5
    

    Here is a screenshot from the "Plugin Info" menu. The Autoactivate and Active options can not be deselected.
    0_1477063860796_PluginInfo.png



  • HI @peter,

    Thanks for the feedback.

    1. This is a known bug and will likely be fixed in a next release.

    2. Same as point 1

    3. This is a new bug we are debugging at the moment. It was known to have worked before, but seems to have stopped working since the latest firmware updates of the wipy and lopy. Yet it's clearly an issue with Pymakr since the CLI telnet still works. We'll let you know once this has been solved.

    4. What kind of error are you getting from the PluginUpdater and exactly when does it occur? Can you send us a screenshot?



Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.