FiPy: upload failed (using Pymakr on VSCode)

  • Hello,

    I have an issue with pymakr and my fipy device.

    At first, the device gave me core dumps, which could be fixed by updating the firmware. Now I have the problem that I cannot upload my code (micropython) to the device – before the update, the upload worked but I received the core dumps.

    The error message looks like this:

    failed to upload /Users/pathname to / Reason: Error: Traceback (most recent call last): File "<stdin>", line 7, in <module> File "<stdin>", line 7, in <module> File "<stdin>", line 4, in <module> OSError: error creating directory '/'

    I tried looking up the error online but I couldn't find a solution.

    The error occurs on different OS and VSCode versions, so I know that it is not caused by my laptop but has to be either an issue with the pymakr extension for VSCode or one of the FiPy device.

    Any help is welcome and I thank you in advance!

  • @Julia-Steiwer As you should have noticed, Pycom Inc ceased it's operation, and there is no service any more for Pycom products, be it hardware or software like Pymakr. The latter should still work with the older VSCode versions. So if you want to use PyMakr, you have to stick with an working combo of an older VSCode version and PyMakr.

  • Since I'm not allowed to edit my own post, here it is in the shape of a reply:

    More info: I have tried the same code, board, and port on Thonny, and it works just fine. It's therefore not an issue of the board but of VSCode and the pymakr extension. I wanted to try it on Atom as well but due to the sunsetting, I cannot install the pymakr plugin.

    My VSCode version:

    Version: 1.82.2 (Universal)
    Commit: abd2f3db4bdb28f9e95536dfa84d8479f1eb312d
    Datum: 2023-09-14T05:59:47.790Z
    Electron: 25.8.1
    ElectronBuildId: 23779380
    Chromium: 114.0.5735.289
    Node.js: 18.15.0
    Betriebssystem: Darwin x64 18.7.0

    Pymakr is version v2.22.5 and "env" and "venv" are being ignored by the extension.

    Even when I completely redo everything, pymakr doesn't upload the code.

    Any idea what might help?

Pycom on Twitter