Pymakr Atom Plugin released



  • With one of the previous versions I encountered a serious error, Atom wouldn't even start anymore. So I deinstalled Pymakr.
    However when I now install it again (tried multiple times) it won't show up anymore. Toggle console does nothing. I can see Pymakr in the packages menu (top menu bar) and I also see it in the Installed Packages menu, where you can change the port etc.

    Atom is updated to the latest version. Maybe I need to clear some old files?



  • Hi @mcook,

    If you look at the bottom of the Atom window, you'll see a new bar with a button that says '^ Open'. If you click this, you will see the new terminal interface.



  • @Ralph

    Hi,

    Maybe I am doing something dumb. When I set up the Atom plugin, by going to Atom > Preferences > Packages > Pymakr, all I see is the PyMakr Readme.

    This is what I see... I don't see a place to configure the IP Address of the LoPy.

    Any idea what I am doing incorrectly?

    Thanks,
    Mike

    0_1496924816310_upload-695f7c17-dac2-45e2-a8ee-f5c0b3682d28


  • Global Moderator

    V1.0.0 has just been released. A few problems concerning the synchronize feature using a serial connection are now solved and some new features have been added:

    • Added project specific settings
    • Added serial port detection (in sub-navigation under the 'more' button)
    • Multiple bug fixes for synchronization over serial
    • Terminal height now resizable by dragging the top edge
    • Fixed 'failed to connect' bug when reconnecting on telnet

    The project specific settings might need some explanation:
    When clicking the new 'project settings' option, a config file is created inside your project folder. Any settings changed inside this file will override the global settings. This can be useful when you are using different project for different devices or when each project has a different folder that has to be synchronized.
    Remove the settings from this file that you don't want to override.



  • @Ralph I re-built the filesystem on each LoPy and now the sync is working. All good.



  • @Ralph Hi Ralph, I installed 0.9.4 and upgraded firmware on my LoPy modules to 1.6.13.b1 and now I can't sync using a serial connection. It was OK with 0.9.3 but I don't know whether to blame the firmware or the Atom plugin update. I am running Atom on a Windows 7 x64 PC.


  • Global Moderator

    Version 0.9.4 has been released with a few bugfixes and stability improvements:

    • Include precompiled serialport libs for mac and linux
    • Improved error handling and stability on sync
    • Running files is now possible for unsaved files
    • Bugfixes for pasting multiple lines and cmd-c/cmd-v commands.
    • Fixed connection issue when using telnet to a device's access point


  • @Andrea-Filippini thank you for the info, i usually use sublime or Visual Studio Code, I am pretty new to Atom.



  • @bnjroos you can find apm in the Atom install location, under /bin folder



  • @Ralph said in Pymakr Atom Plugin released:

    Hi @bnjroos, Good to hear! For future reference, there is a short instruction for 'manual install' in the readme file on the develop branch

    Yes but on windows I don't have apm installed by default hehehe. Maybe a 'npm install' should be added to the manual.


  • Global Moderator

    Hi @bnjroos, Good to hear! For future reference, there is a short instruction for 'manual install' in the readme file on the develop branch



  • @bnjroos said in Pymakr Atom Plugin released:

    On windows 10 I cannot see any package named pymakr when searching in the installation tab and when i try to install it manually i get thee following:
    0_1493263990828_atom_2017-04-27_10-31-40.png

    How to install the pymakr plugin sucessfully ?

    Thanks,

    Found the solution by running npm install inside the package folder.

    Thanks


  • Global Moderator

    Hi @cylex, The same problem (in a different form) was reported in this topic and the bug was fixed (on the develop branch only, not yet released). Very likely this fix also solves your issue. You can do a manual install from the develop branch to test it if you want, or wait for the next release.



  • On windows 10 I cannot see any package named pymakr when searching in the installation tab and when i try to install it manually i get thee following:
    0_1493263990828_atom_2017-04-27_10-31-40.png

    How to install the pymakr plugin sucessfully ?

    Thanks,



  • Hey there! So after testing the plugin for a few days I have to remark that debugging with the pymakr Plugin is quite hard. When it comes to an error the compiler output is often times incomplete and changes after running the same error-having code for several times... However, the compiler output is complete when I use my terminal.


  • Global Moderator

    @pwest @smssms If you have time, please test the code on the develop branche on github (instructions for manual installation are in the readme file on the develop branch). This code contains pre-compiled versions of the serialport lib for both mac and linux (64 bit), which should solve both of your issues.
    Let me know if it works.



  • @smssms Same problem on Linux Mint 17.3, Cinnamon, 64-bit



  • @livius

    ping is OK
    telnet is working
    i can connect on the python interpreter with the default login / password

    only Atom/Pymakr is not working

    @pycom please help



  • @tuxtof
    First test if your ping reach device
    show us response

    ping 192.168.4.1
    


  • Same problem for me

    0_1492846714191_upload-6fcc324a-8297-44d7-90de-abf0717b00be

    MacOS X 10.12.4
    Atom 1.16.0
    Pymakr 0.9.3
    Lopy FW 1.6.12.b1

    any other solution to use my Lopy ?


Log in to reply
 

Pycom on Twitter