Is it just me or is Pycom sofware not very good?

  • I tried PyMakr and it would not talk to my WiPy. Two other people at work tried it (on Windows, Linux and Mac) and they could not get it to work properly either.

    I tried Pymate on my Samsung Galaxy and it is unusable as it cannot see any router SSID (see my other post).

    So now I tried the Atom PyMakr plugin and guess what - will not load! I get the 'serialport' error. I tried all the fixes listed in the Git fault report with no success.

    To use my Pycom hardware, I use Geany, Linux terminal (Telnet) and Firefox FTP plugin.

  • @smssms I feel like I may be with you on this one I have yet to find a combination of H/W Firmware and tooling that is reliable. I wanna believe. It looks so promising and so close yet just not quite ready I think.

  • How are you connecting the WiPy to Pymakr - Serial or over Telnet? Are all the headers ( TX , RTS, RX ,CTS etc) still attached on the board?

  • Hi @smssms,

    For the Pymakr Atom Plugin, please file a new issue (or re-open the previous one) on github, with the stacktrace, version info of your system and a description on how to reproduce. All previous reports of this issue were solved with the fixes posted on github, so yours is a new issue.

    The old Pymakr is not maintained anymore, but should definitely still talk to your WiPy. If others tried it as well with the same WiPy, perhaps the issue is there. Update to the latest firmware and test connectivity after safe-booting.

  • Pybytes Beta

    @robmarkcole said in Is it just me or is Pycom sofware not very good?:

    PyMakr is no longer supported

    The main problem is that the docs are old, outdated and misleading. Although the API seems to be quite reliable.

    I'm currently working with Putty (Telnet) and Filezilla (FTP). This seems to be a nice, working tool combination.

  • PyMakr is no longer supported, so wouldn't put effort into that. The pymate app I had a bad experience with on iOS, but not really necessary. Had a few issues with the atom plugin but now resolved and working nicely on Mac. Since the plugin was only released a couple of days back I think a few bugs are to be expected :-)

Pycom on Twitter