cannot synchronize, neithe transfer through ftp **SOLVED**



  • Hi all!
    I´ve received my brand new LoPy device last night, i´ve been trying to get the basics running.
    Many things are working, but there are a couple of important things that i cannot do yet.

    1. Synchronize

    When i press the sync button on atom i got this:
    0_1493821363975_upload-5d9c3fa7-1da1-4dc5-998f-ade7e9d57e40

    1. When i got connected to the LoPy through ftp at 192.168.4.1 the connection is established with no problems, but when i try to download or upload a file i always get a connection error
      0_1493821493410_upload-6f93449d-d717-4fb9-817e-014fb9bc441f

    There's an important thing to clarify, i´ve not connected the LoPy module to the expansion board (i dont have one). It means that i have made the connection manually... hope to have it done right.
    Lower side cables are VCC/GND (5v), upper side cables are RS232 connection, left side cable is wifi antenna.

    0_1493821887117_upload-93d8b480-58d6-4c3e-ad6f-b879a6cc0af4

    Regards,

          Pablo Caviglia


  • Hey @livius,

    that did the trick, again! Thx a lot, that makes even easier the deployment process, and i´ve also learned pretty nice stuff in the meanwhile.

    By the way, i first tried to make it work by cloning the project 'master' branch, but that code wasn´t making the deal yet. To make things work i had to clone the 'devel' branch (that by the way it´s weird because it´s one version behind 0.9.3 than master 0.9.4).

    0_1493908814839_upload-f0ec380b-2af6-42cb-908e-3ed47257fabf

    Thx a lot again man, saved my life!



  • @pablocaviglia
    Some errors in Atom plugin was fixed - but not released yet
    You can build it from code
    https://forum.pycom.io/topic/1026/pymakr-atom-plugin-released
    https://github.com/pycom/pymakr-atom



  • @livius

    Re: [cannot synchronize](neithe transfer through ftp)

    Correction about last post. The sync process through atom isn´t working, but after doing what you've recommended about transferring 1 file at a time through ftp works fine!

    My intention is just to transfer new code to the lopy, so the ftp solution is enough for me. The 'sync' button at atom is a nice thing to have, but it can be replaced with the ftp transfer... so from my side this issue can be closed.

    If anyone wants me to make some extra tests with atom (just to make it work), i will be glad to do whatever test is necessary, or debugging, or something else, so just ask and i will do.

    Thx a lot for the helpful information @livius



  • @livius

    Hi again, and thx for the fast response.
    I were able to update the LoPy firmware, and now i understand why with the previous firmware didnt work the wlan.ifconfig() function, it wasn't implemented yet.

    Anyway the problem with the sync still happens. If i try to sync the code through the atom ide, or even while trying to transfer new files through FTP, i got a timeout, and even the REPL console on atom gets hanged up.

    0_1493866731462_upload-7514064c-4cc2-49ee-93d2-29d94fba74ab

    This image is the booting process after upgrading, please confirm if it´s the latest one.

    Thanks in advance, and let me know if you need some extra information to help me get this working. I'm on the middle of a project and time's not friend of mine... as usual :)

    reply



  • This post is deleted!


  • @pablocaviglia
    First i see that you have older firmware i look at Micropython date.
    Please first upgrade firmware.
    If you have TTL UART/USB converter than this is simple:
    https://docs.pycom.io/pycom_esp32/pycom_esp32/getstarted.html?highlight=upgrade#firmware-upgrades

    second - remember to set in your ftp tool to set limit to one connection only.
    https://docs.pycom.io/pycom_esp32/pycom_esp32/toolsandfeatures.html?highlight=filezilla#filezilla-settings



Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.