OTAA Node says 'Not yet Joined..'



  • Hi,

    I've set up a nano gateway and was able to connect it to TTN. But, I was not able to connect the LoPy Node to TTN/Gateway. It says 'Not yet joined..'.

    I'm using the codes by Daniel from ''examples'' and tried to print the Lora frequency using lora.frequency( ) and the output is '868000000' instead of '868100000'.

    Can anyone help me understand what am I missing?

    PS: I'm working from India.



  • Even after repeated attempts, unable to get my node working. I tried Sodaq One and lopy nano gateway which worked fine. So, I'm guessing there is a problem with my other LoPy which I'm trying to use as a node.

    Thanks everyone for your help.



  • Thanks @RobTuDelft for the Scripts, I'll recheck the EUI and if it still doesn't work, will try with your codes.



  • @avinash Did you register using the correct device EUI? This can be obtained from the LoRa radio. You can upload this script to both the Lopy gateway and the node to find out their respective EUI's and register them correctly with the TTN using these EUI's.

    For the nano gateway you can use these files and for the lopy nano gateway compatible node that connects through OTAA with the gateway you can use these files. These I can confirm to be working for me.



  • @RobTuDelft Thanks Rob, I'm using pretty much the example code now. PFA the same, but the TTN console status says 'never seen'.0_1495463359109_ABP2.JPG

    I'm just wondering if I can tweak the nanogateway code a little and check if I can setup a standalone gateway without linking it to TTN and check the Node range.
    Any thoughts on this?



  • @jmarcelino Initially they were on the same table, thanks for the suggestion. Now I'm trying with keeping them 30 feet apart, but still no difference.



  • @avinash You have s.send("Hello") and on the next line you are sending again. Also, I can see you changed the order of join and removing/addding the channels. Debug in small steps.



  • @avinash
    How far away is the node from the gateway? LoRa works better when you have some distance between the two (e.g. not on the same desk). Of course if it's far away there's other issues at play.

    Also what are you using as antennas and are they correctly connected to the connector next to the LED?



  • @RobTuDelft I've tried reflashing the device. I've manually replaced the keys in the code. This is the code I've used -
    0_1495273543918_ABP_Code.JPG

    In the ABP code I just added the lora.has_joined( ) part and the program did pass through the part. I'm assuming that means the Node has joined the LoRa network, but I'm not able to receive the data yet and TTN Console says device 'never seen'



  • @avinash Maybe try these things:
    Make sure you flash the device with the correct regional setting and the latest firmware.
    Also check your antenna connections.
    Did you try to send something? There is no handshake procedure with ABP, you usually enter your keys manually in a config.py file.



  • @RobTuDelft Yes, I did. It's showing 'never seen' in the console. I just tried using ABP method as well, but the device status in console is same.



  • Did you register the Lopy node (using the example code) at TTN under applications?


Log in to reply
 

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.