[SOLVED] Cannot Connect



  • I have two LOPYs and two Pysense boards. I did have it working but now I cannot get them to connect via USB or telnet

    About two weeks ago I got one of the Lopy working on a Pysense and was able to get access via serial and Telnet.

    Then I realized I needed an expansion board to upgrade the firmware on the Lopy. When that arrived (two days ago) I went to first upgrade the firmware on one of the Psysense as per the post "How to pyTrack and pySense firmware upgrade in Windows"

    I followed the procedure without a Lopy installed and I initially used Zadig but it installed the wrong driver. And the next step is where I may have caused the problem. I saw Pysense listed as an installable option and so hit the install driver. After I realized my mistake I then used the drivers supplied by jmarcelino and I followed the procedure as per his original post.

    Anyway I finally got a "Done with no errors" from the Pysense so I went to connect to the Lopy. I tried to do a firmware upgrade on one of the Lopy but it would not connect over USB.

    So far I have tried both LOPY in both a pysense and an expansion board and I get the same results - NOTHING.

    The LOPY LED is blinking blue every 4 seconds like its supposed to. My windows 10 Network Settings page is showing that the LOPY Wifi is up and running but it will not connect. Telnet will initially connect and echo whatever you type (sometimes) but then it closes with a software caused abort. On a serial connection nothing appears unless the reset on the Lopy is pressed in which case it prints out a bunch of garbage but sometimes prints out a portion like " rtc v134 Oct 20 2016 12:36:18˜øXTAL 40M"

    So far I have tried installing the FTDI drivers. Used another usb cable which I know is a data cable). Tried another PC. Uninstalled usb com pots.

    Anybody got any clues as to what I need to do



  • USB issues SOLVED

    The problem was the baud rate being used by Putty. The default baud rate in Putty is 9600 but the rate that should be used is 115200. This is mentioned in the documentation section for using Linux .

    After I changed the baud rate to 115200 did that Serial USB was working.



  • Thanks for that.
    I carefully reread the FTDI installation instructions and realized I only had done HALF of the USB driver install procedure. It seems you have to install drivers for the Com Port and then the Serial Bus Controller. I did a manual update driver for both using CDM v2.12.26 WHQL Certified.zip. I am running Windows10. I hope this is the correct driver because the default drivers installed by Windows would not work.
    Anyway got a COM3 port installed and did a firmware upgrade of a LOPY on the Expansion board. This succeeded so I thought the Com Port must be working.
    But then I removed the connector from G23 to Ground and reset the Lopy with the button next to the LED. Started Putty using the same COM3 port and get same result as yesterday eg no display unless I press the reset and then I just get garbage. I tried a Control C but that did nothing. So despite doing an upgrade and telling me it succeeded it will still not communicate over Serial. I checked that Putty was set up as per the UART documentation but the documents don’t say anything about flow control so I tried all options. I checked all the jumpers were installed and shorted out with a multimeter. I left them all connected?
    However after the upgrade I WAS able to connect via TELNET on Putty This however required an additional step that is not mentioned in the docs. First I had to get the Wifi card to connect to the Lopy via the Windows Network Settings Menu. This might be obvious to others but it wasn’t obvious to me so I mention it for the benefit of others. BTW FileZilla gives the Lopy welcome message but then states cannot connect?.
    So in summary I think I upgraded the Lopy (the Login screen says “MicroPython v1.8.6-715-g5fal6c2c on 2017-07-20") I can get Telnet connection via Putty (but not via FileZilla) but cannot get USB serial. Telnet will also work on the Pysense but no serial.
    I am wondering if the USB driver is the issue. Can somebody confirm which USB driver is supposed to be used for both the Expansion board and a Pysense. I am also wondering if the board is somehow maintaining a WIFI connection and will not allow a serial connection at the same time?
    BTW I also tried to get ATOM running to see if I could access the serial port from it. But the board does not show up. And Pymakr fails to install and I don't have the knowledge or the time to sort that out. I suspect it won't work because it cannot see the serial port. So anyway unable to test the serial port with Atom.

    Any additional help appreciated



  • I would focus on doing a fresh firmware update on the LoPy:

    If the Expansion Board serial port doesn't show up, open Device Manager and try unplugging and plugging it back it to see if anything changes there.

    If it does show up but just can't communicate try this guide, especially about checking all the jumpers on the expansion board: https://forum.pycom.io/topic/763/firmware-upgrade-troubleshooting-checklist-procedure



Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.