LOPY Update failed



  • I just received 2 new Lopy with epansion board. The only message is:
    "The upgrade failed, please check the connection and try steps again".
    I am using WIN10. When i connect USB cable to Port i see a new Serial port (COM5) but i get no Connection. I tried 2 LOPY´s. and I also updatet FTDI. I checked 4 different USB-Cable. There is also no connection to PyMakr.
    What can i do else?



  • @Willi, glad to hear it worked after you set up the missing jumper. I'm now closing this thread as solved.



  • @Willi Now it works. Thanks to Abilio. We found that factory forgot to set one Jumper.


  • Global Moderator

    Did you connect GND to G23 and press the reset button on the board before starting the updater?



  • @abilio Sorry for delay, I was at lunch.
    I used the update Software download from getting started., yesterday!
    0_1478002554096_pycom_fail.jpg



  • Hi @Willi, as @Xykon mentioned, the last updater tool for Windows should also open a command prompt dialog on the side/back. Can you confirm this is the case? If not, you're using an outdated tool known for this failure you're describing.



  • @Xykon Thank you for prompt answer.
    I tried this and now I have Connection to Tera Term.
    But why does your Pycom Firmware update not work?


  • Global Moderator

    @Willi
    Baudrate: 115200bps
    Data: 8bit
    Parity: None
    Stop: 1bit
    Flow Control: None



  • @Xykon Hi,

    Yes i am also using Tera Term but i dont know the Setting;
    Baudrate
    Data
    Parity
    Stop
    Flow Control
    Where can I find These Settings?


  • Global Moderator

    Please install a serial terminal program like putty or Tera Term to check the output from the LoPy.

    When you have G23 connected to GND and press the reset button on the module, you should see the following output:

    rst:0x1 (POWERON_RESET),boot:0x3 (DOWNLOAD_BOOT(UART0/UART1/SDIO_REI_REO_V2))
    waiting for download
    

    Also the latest firmware update should have a command window with more output. Please make sure you downloaded the latest version and post the output from this window.



  • @Xykon whis the updater i get:
    "The upgrade failed, please check the connection and try steps again".
    and in PyMakr i only see::
    "Error while communicating with the Pycom device!(Click to attempt to reconnect).
    green LED is on, orange LED is half on, blue LED is blinking all 4 seconds.


  • Global Moderator

    What exactly do you mean by "i get no Connection"?

    Which terminal program are you using?

    Do you get an error message connecting to the serial port or do you simply get no output from the module?


Log in to reply
 

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.