LoPy stops working after a few seconds

  • Hi,

    I've managed to get my LoPy to communicate with my computer via serial (no expension board, FTDI USB to TTL converter). I've upgraded the firmware by downloading the tool (I use Linux Mint 18.2), and I had the message "your device was successfully updated to 1.7.9.b3".

    But when I boot the LoPy, the serial console or WiFi AP is reachable only for 20-30sec. Then the heartbeat blue LED stop, serial console unreachable and WiFi SSID no more visible.

    I tried to use the safeboot mode (release P12 after orange flash quickly), but same issue. I don't know why, but once the LoPy worked for almost 10min, but now it's back to ~30secs.

    I also tried to input the following code in LoPy's console to flash the memory:
    import os

    But no more luck..

    What could be wrong?

  • @chriseb Which firmware version are you using? The latest release 1.17.3.b1 seems pretty stable.

  • @robert-hh Yes, understood - the problem here is that the device was previously working correctly [with the same reliable power supply that it is now using], it started playing up after a firmware upgrade.

  • @chriseb I have two device running with a plain vanilla FTID USB/TTL converter without any problems, one now for 4 weeks uninterrupted as LoRa nanogateway. You must care, that the Pycom device is running from a reliable 5V supply, USB or another source, and the logic levels of TX and RX of the FTDI board are set to 3.3V. The standard Vcc output, when set to 3.3V, cannot supply sufficient power. Not all FTDI boards have a separate output for 3.3V and 5V.

  • Have experienced the same thing with my wipy - which I reported in a previous thread - trying to debug it again recently and it seems this is an endemic problem with this set of boards - there are plenty of threads on similar issues on this forum, and no official response at all.

  • Ok, so I've tried the following:

    • deinit Wifi in the main.py
    • changed power supply with a better one running at 5V@2A

    It seems better now, but still stops running without reason after a while... Friday it has ran for 5 hours until it stopped. In my main.py I have a while true loop that changes led colors, with some time.sleep(XX) between each color. When the LoPy stops, le LED stays off, so I assume the python script is not running anymore, and I have no more serial connection neither.

    What could be wrong?

  • @jmarcelino thanks for the quick answer!

    I've put my LoPy on a breadboard, on which + and - lines are powered by a 5V@1A USB adapter (red/black wires).
    LoPy 5V and GND pins are connected respectively to + and - lines of breadboard using male/male jumpers.

    This seems to be very random, I've just tried again and it has been 5min since LoPy is reachable... I will take a look about disabling Wifi.

  • This post is deleted!

  • @jturello
    Could be a power supply issue. How are you powering the LoPy?

    WiFi in particular has a lot of current spikes, as a test you can try to deinit WLAN and see if it stays up longer.

Log in to reply

Pycom on Twitter