"Unable to find folder" using sync with Atom.



  • Sync folder is set in pymakr.conf for the project but the file won't sync. I'm trying to use a folder off my home folder in Linux.



  • Yup, problem is sorted. Thanks.



  • @ralph, that's awesome. I'll have to do that next week but I'm pretty sure that'll fix it. Many thanks.


  • Global Moderator

    @alidaf Ok good, that's one step further!

    The last release caused this sync error to happen with some users. Try updating to the just released 1.1.4 version of Pymakr and try again.



  • Hi @ralph ,

    I couldn't delete .atom from the menu so I deleted it from the filesystem. I had to reinstall pymakr but i now have just a single project folder.

    Syncing now gives:
    Synchronizing failed: timeout. Please reboot your device manually.

    I tried moving just main.py into a subfolder and changing the sync_folder setting but I get the same error.


  • Global Moderator

    @alidaf Thanks, I see the problem now. You have 2 folders open in atom as 'projects': one is '.atom' and one is 'git'. Pymakr doesn't detect which project is currently open, so it alsways uses the first in the list, whenever you use actions like "Project Settings". If you look at the file paths you'll see that pymakr.conf has actually been placed inside '.atom'.

    Solution for now is to remove the .atom folder from your projects list on the left. After that click 'project settings' and it'll create a pymakr.conf file in the 'git' folder. Or you can move the current one from .atom to git.

    In the meantime I'm trying to find a way to build in multi-project support for Pymakr. That will solve this issue.



  • Hi @ralph,
    Thanks for sticking with this. I still can't sync so I've attached a screenshot.

    I've tried git/chargepoint as well.

    0_1506677971147_Atom01.png


  • Global Moderator

    The src/files content was just an example, to be clear :). The sync_folder just has to be the folder name relative to your project folder. If you want to sync the files in the git directory in your project, put "sync_folder": "git" in your config file. Just tested it (on mac) and seems to work fine. Will test it on ubuntu in a moment just to be sure.



  • Hi @ralph, I still can't get it to sync. I have listed under Project in Atom a folder called git. Below that are some project subfolders. I've tried src/files and also adding a higher level up to git, i.e.
    src/files
    chargepoint/src/files
    git/chargepoint/src/files
    but all of them fail...

    Unable to find folder 'src/files'. Please add the correct folder in your settings
    Unable to find folder 'chargepoint/src/files'. Please add the correct folder in your settings
    Unable to find folder 'git/chargepoint/src/files'. Please add the correct folder in your settings

    I'll probably kick myself when the error is pointed out but I really can't see it.


  • Global Moderator

    Hi @alidaf, make sure the sync_folder is inside the project that is opened, and you put the relative path in it (without a / in front of it).
    So, if the opened project is in ~/projects/wipy and you want to sync the ~/projects/wipy/src/files folder to the board, put src/files in the sync_folder config.

    Let me know if that helps. If not, it would be helpful to have a screenshot of the error you're getting.


Log in to reply
 

Pycom on Twitter

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.