Bricked device.



  • I've had a number of problems with the 4 SyPy boards I have, especially with updating the firmware. One in particular has persisted in refusing to update using the bash script. I tried updating with a Windows machine and it appeared to work but now the device has a permanent red LED.
    I tried using the Windows update again, and again it appeared to work, but I still have the red LED.
    Is this completely bricked now?



  • @robert-hh I had to connect G23 with GND as per the update process. The update failed 3 more times with the bash script but the last one using windows seems to have worked.
    Someone needs to work on the bash script!
    Many thanks for the help.



  • @robert-hh I get an error: A fatal error occurred: Failed to connect to Espressif device: Timed out waiting for packet header. The LED is now yellow.



  • @alidaf If the device shows a red LED then it still works, but just the firmware configuration is messed up. Try to erase the flash completely and re-load the device. Erasing is done with esptool.py, V2.01. Prepare the device like you would to uploading: connect G23 to GND and push reset. The command is:

    python esptool.py -p <your_com_port> -b 460800 erase_flash

    After that, you should be able to re-flash the device.


 

Hello World?

Pylife on Kickstarter - November 2018








Back Us On Kickstarter >

Pycom on Twitter