wrong serialport selected and copied to clipboard on initial config

  • Pymakr 1.2.0 running on Atom 1.21.2
    on reconnection of a LoPy board on a PySense devboard via USB

    On launch I ran More -> Get SerialPorts
    PyMakr then correctly identifies active ports, but then selects the wrong COM port (copied to clipboard)
    as the wrong COM port is selected this obviously leads to no serial connection with the LoPy

    The serial connection runs fine on TeraTerm.

    I have looked across the Forum but cannot see anything similar to this issue.

  • OK now works!
    I changed the device address in the global settings to the correct Com port and rebooted Atom and it picked it up fine.
    Thanks again, @seb, rather strange this has only just started to happen!

  • Yes, if you click the "settings" button in the pymakr panel you get two options, global or project settings. If you select global you can then set the com port that pymakr will use for all projects unless the project has its own settings. If you select project settings you can set the com port for the selected project, which will override the global setting.

  • yes @seb I have done this set up months ago and things have been working fine.

    step 4 states
    Click, 'More' followed by 'Get Serial Ports'. This will copy the serial address of your expansion board to your clipboard.

    This has been working fine (automatically selecting the correct serial port used by the devboard) until i started up Atom today. Now it has started to select an incorrect port.
    Can I manually override this somewhere in the settings?

  • This page should guide you through configuring pymakr to connect to your device https://docs.pycom.io/chapter/gettingstarted/installation/pymakr.html

  • thanks @seb, how do I manually set that parameter in Atom's Pymakr or did i understand you correctly?

  • Im afraid pymakr doesnt allow you to select which port to copy to the clipboard at the moment. You will have to manually type in the name of the correct com port for your setup.

Pycom on Twitter