Starting with LoPy



  • I received 2 LoPy and 2 expansion boards today.
    I followed the initial setup instructions and got my units connected to Visual studio code pretty easily.
    I ran through the examples of changing the LED colour and then LoPy to LoPy. I am not sure what happened, I can 'run' scripts but I can no longer upload them to the boards. I get this message:

    Upload failed.: Cannot read property 'split' of null.

    I also can't get the pycom upgrade tool to function at all.
    I have also tried putting a brand new (untouched) module in the expansion board and trying to run it through the initial firmware upgrade but it hangs at "Getting board information" the same as the other boards.

    Hopefully I have just made some sort of newbie mistake. Any guidance would be appreciated.



  • @aimette You can set up your own firmware build environment from the repository at https://github.com/pycom/pycom-micropython-sigfox, which in addition to changing the frequency allows you to embed your Python code into the flash, if it solid.



  • Update:
    I have installed Atom - which works without issues. I have also installed ampy and that works no problems at all.
    I suspect the problem is in a driver/VS code. I am still unclear as to why when I installed VS code on a different computer I see the exact same errors.
    The pycom upgrade tool still isn't working properly for me on either computer.
    Is there a way to perform firmware upgrades without the updater? More specifically, changing the LoRa frequency range from 868MHz to 915MHz and visa versa?



Pycom on Twitter

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.