[Solved] issues w/ serial connection: Atom + LoPy



  • Edit: solved via Safeboot, thanks @Seb.

    Hello,
    I successfully updated the LoPy1 to the latest pycom firmware, and I installed the pymakr plugin for Atom on Windows 7 machine. But when I try to connect to the LoPy via Atom's serial connection tool, I don't get the same results as the Getting Started Guide. Here's what I see. I'm not getting the >>> in the console, and I can't type anything in. Here's a screen shot of what I see.

    https://s18.postimg.org/5ya30gjhl/pycom_error_connection.jpg

    alt text

    https://s18.postimg.org/o135rvpop/pycom_error_settings_wrong.jpg

    alt text



  • @seb Yup, that solved it



  • Hi,

    Do you have any code running on the device? If so, this could prevent the REPL prompt from appearing. Try clicking into the terminal window and pressing Ctrl+C. This should kill whatever script is running unless it is blocked.

    If Ctrl+C does not work, you could try doing a "safe boot" of your device to see if this fixes the issue. When P12 (bottom left most pin) is attached the 3.3v an the device is rebooted, you will see the on-board LED blink orange. When you see this, it mean the board will no longer run boot.py and main.py and go straight to the interactive REPL prompt.


 

Hello World?

Pylife on Kickstarter - November 2018








Back Us On Kickstarter >

Pycom on Twitter